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Résumé


Maîtrisez Java et votre Raspberry Pi


Le langage Java et le nano-ordinateur Raspberry Pi sont deux outils incroyablement populaires et pédagogiques dans le monde des technologies actuelles. Cet ouvrage les réunit, dans le but de vous apprendre à programmer en Java en réalisant différents projets simples d’électronique avec un Raspberry Pi 3 (modèles B, B+, A+ et Zero WH).


Le livre débute par l’installation et l’utilisation de l’environnement de développement Eclipse pour Java, puis présente le port GPIO du Raspberry Pi, en s’aidant des schémas produits par Fritzing. Il utilise ensuite des scripts Python pour tester des composants montés sur une platine de test. L’apprentissage de Java s’effectue en douceur à l’aide de la librairie Pi4J qui gère le port GPIO : d’abord avec des LED, puis en utilisant un relais et différents capteurs (de mouvement, lumière, température…). Vous apprendrez aussi à programmer un serveur web en Java grâce à l’accès Wi-Fi du Raspberry Pi. Enfin, vous manipulerez une base de données SQLite avant de réaliser le projet final : l’envoi d’un e-mail depuis le Raspberry Pi avec la photo de l’intrus entré dans votre logement !


Ce livre d’une grande richesse de contenu est complété par 120 exercices corrigés, dont les solutions sont disponibles en ligne.


À qui s’adresse ce livre ?


• Aux débutants en programmation Java


• Aux amateurs d’électronique souhaitant programmer en Java


• Aux étudiants et aux makers




Au sommaire


Java et Eclipse • Installation du Raspberry Pi 3 B • Putty et WinSCP • Le port GPIO du Raspberry Pi • Python pour vérifier les fonctions GPIO • La librairie Pi4J • Clignotement d’une LED • Débuts en Java • Une classe Java pour lire et écrire des fichiers • Exceptions en Java • Tâches en parallèle avec les Thread • Exécution de scripts Python depuis Java • Création de deux classes • Relais 5 V – 220 V • Capteur de lumière • Capteur de mouvement et buzzer • Capteur de température • Capteur à ultrasons et bouton-poussoir • Java et les fichiers .jar • Caméra Pi • Serveur web sur le Raspberry Pi • Base de données SQLite • Envoi d’e-mails depuis le Raspberry Pi.
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Avant-propos


L’idée de ce livre m’est venue lorsque je testais un capteur de distance sur le mini-ordinateur monocarte Raspberry Pi 3 B. Pourquoi ne pas faire partager mon expérience en Java sur le Raspberry Pi, dans un environnement Linux et avec des outils comme Eclipse sous Windows ? Le langage Java et le Raspberry Pi sont en effet deux outils incroyablement pédagogiques et populaires dans le monde des technologies actuelles.


Que contient cet ouvrage ?


Le but de ce livre n’est pas de couvrir toutes les constructions et les astuces du langage Java, mais de donner suffisamment d’informations pour les débutants, afin de développer de petites applications pour et sur le Raspberry Pi 3 B ou équivalent. C’est un Raspberry Pi nu qui sera considéré, sans écran ni clavier, un vrai objet connecté. L’installation pour une utilisation comme un ordinateur Linux traditionnel sera aussi examinée.


L’outil de développement choisi est Eclipse et je vais considérer que le lecteur a peu ou pas de connaissances avec cet environnement plutôt complexe. Dès que nous le maîtriserons suffisamment, nous ne pourrons plus nous en passer. C’est la raison pour laquelle j’ai présenté un grand nombre d’exemples et d’astuces. Eclipse, c’est tout de même un petit monstre !


La présentation de Java est illustrée par différents exemples et exercices, avec en toile de fond l’apprentissage progressif des outils, de la plate-forme Raspberry Pi 3 B et de son Linux Raspbian. Le langage Python est également présenté car il est indispensable pour vérifier les circuits connectés au port GPIO et avant toute programmation en Java.


Dans cet ouvrage, je commencerai par détailler les installations d’Eclipse et du JDK de Java. Puis nous démarrerons la programmation Java dans un environnement Windows avec un traditionnel Hello World sous Eclipse. Ensuite, je passerai sur le Raspberry Pi 3 avec des composants attachés aux broches du port GPIO et leurs schémas Fritzing. Des sujets comme la lecture de fichiers, la création d’un serveur web, la prise de photos, l’envoi d’e-mails ou encore l’utilisation d’une base de données SQLite nous feront rapidement progresser dans l’apprentissage du langage Java et de la plate-forme Raspberry Pi 3 B.




Le port GPIO du Raspberry Pi


Le port GPIO, ou l’interface GPIO, est une extension contenant des broches permettant de se connecter à des composants électroniques. Nous y trouverons évidemment des broches de tensions (3,3 V et 5 V), mais aussi des entrées/sorties digitales et de communication. Ces broches digitales accueilleront aussi bien des LED à allumer ou éteindre, des relais 220 V pour enclencher et déclencher des appareils, que des capteurs de lumière, de mouvement ou de température.


Cette « électronique » associée à la puissance d’un Raspberry Pi connecté à Internet et à des outils comme Linux, Java ou Python, donne à la fois un environnement enthousiasmant pour les passionnés de nouvelles découvertes et la raison d’un tel ouvrage.


J’ajouterai que, même si le Raspberry Pi 3 B n’a pas les fonctionnalités analogiques et temps réel d’un Arduino, il possède néanmoins toutes les capacités pour écrire du logiciel conséquent. L’Arduino et le Raspberry Pi sont donc en fait complémentaires.





À qui s’adresse ce livre ?


Cet ouvrage s’adresse tout d’abord aux makers, aux bricoleurs et aux passionnés de programmation et de découvertes.


Il y aura ceux qui connaissent déjà le langage Java, mais peut-être pas tous ses aspects ; ils auront sans doute acheté le livre en consultant la table des matières et les nombreux exemples.


Certains auront déjà travaillé avec un Raspberry Pi, voire avec un Arduino. D’autres auront déjà joué avec des composants électroniques et des scripts Python. Ce dernier langage est incontournable et il constituera une partie importante de cet ouvrage.


Enfin, ce livre intéressera aussi tout débutant sans connaissances en Java et Python, ou de l’environnement Linux, mais ayant une bonne base de programmation dans un autre langage.


De quoi a-t-on besoin ?


Pour le développement, je n’ai considéré ici que l’environnement Windows 10. Mais certains outils comme Eclipse existent aussi sous Linux (Ubuntu, par exemple) et sous Mac. Des programmes comme PuTTY ou WinSCP ont également leurs équivalents dans ces systèmes d’exploitation. Le lecteur pourra consulter le site web de l’auteur pour un environnement Ubuntu.


Un bon PC équipé d’un processeur i5 récent bien cadencé et de 4 Go de mémoire vive est suffisant pour assurer une compilation rapide des programmes et garantir un environnement agréable pour le développement.


Plusieurs outils traditionnels Windows sont utilisés sans être décrits en détail, comme l’extracteur de fichiers ZIP.


Un accès à Internet avec Wi-Fi est nécessaire. Le routeur, par exemple, nous permettra d’attribuer une adresse IP au Raspberry Pi 3 B. J’utilise Chrome et Firefox comme navigateurs pour les exemples dédiés au Web.


Il faut se procurer un Raspberry Pi de dernière génération, c’est-à-dire un Pi 3 B ou équivalent. Une alimentation classique avec un câble USB est nécessaire, ainsi qu’une microcarte (microSD). Nous verrons tout au long de l’ouvrage un certain nombre de composants électroniques dédiés au Raspberry Pi : LED, relais, capteurs de présence ou de lumière, etc.


Enfin, plusieurs appareils sont pratiques, mais pas obligatoires, comme un multimètre, tellement facile pour vérifier une tension ou une résistance sans utiliser le codage figurant sur le composant.


Pourquoi autant d’exemples et d’exercices ?


À mon sens, il n’y en a jamais assez et ce livre pourrait très bien être utilisé comme base d’enseignement dans une école et comme outil d’apprentissage.


Lorsque nous débutons en programmation, nous commençons par écrire de petits morceaux de programmes. Ensuite, nous passons à des exercices plus complexes en intégrant d’autres fonctions ou composants. L’essentiel est d’écrire du code, beaucoup de code. Un bon programmeur sera toujours un collectionneur d’exemples, d’essais et de programmes, qu’il pourra rapidement retrouver et adapter lorsqu’il en aura besoin.


Les exercices m’ont aussi donné l’occasion de vérifier la consistance et la structure de cet ouvrage. Ils aideront en outre les lecteurs à suivre leurs progrès.


Tous les exercices sont en principe faisables, mais je ne les ai pas toujours codés entièrement, car ils viennent souvent d’idées qu’il faudra expérimenter et qui pourraient devenir des projets informatiques vraiment conséquents.


Stockage du travail sur ordinateur


Il nous arrivera de créer de petits scripts Linux ou Python directement sur le Raspberry Pi, mais ce dernier n’est pas forcément l’endroit le plus sûr pour garder nos fichiers. Il est donc conseillé de bien stocker son travail sur son PC.


Les éléments à sauvegarder seront :


•l’espace de travail d’Eclipse avec tout le code Java ;


•les scripts Linux et Python du Raspberry Pi ;


•d’éventuels scripts Python pour apprendre le langage sur son ordinateur ;


•les images de sauvegarde du Raspbian du Raspberry Pi 3 (voir chapitre 3).


Commentaires et suivi de l’ouvrage


J’apprécierai très volontiers de recevoir des commentaires et critiques de cet ouvrage à l’adresse électronique suivante :


À : jean-bernard@boichat.ch   Objet : Java et le Raspberry Pi 3


Sur le site web http://www.boichat.ch/javaraspberry/, vous trouverez en fichiers .zip les codes sources des exemples, les solutions ou des pistes pour les exercices, d’éventuelles corrections, ainsi que des remarques pertinentes ou des difficultés rencontrées par certains lecteurs. Après extraction, il faudra absolument utiliser Notepad++ pour s’assurer de lire correctement les fichiers texte. Vous aurez également à votre disposition des informations sur les nouvelles versions des outils et des modèles de Raspberry Pi, ainsi qu’une liste de sites et d’ouvrages intéressants et recommandés. Je mettrai toutes ces informations régulièrement à jour avec d’éventuelles adaptations et améliorations.
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Java et l’environnement de développement Eclipse


Pourquoi Eclipse ?


Eclipse est avant tout un éditeur de code source et un environnement de développement open source gratuit. Il est utilisable pour différents langages de programmation, comme Java ou C++. Le site de référence de la fondation se trouve à l’adresse http://www.eclipse.org. Il y a évidemment d’autres outils possibles, parmi lesquels nous citerons évidemment NetBeans (https://netbeans.org/), gratuit aussi et tout à fait comparable. Le premier est plus un choix professionnel, surtout pour le travail en entreprise et en groupe.


Eclipse n’est pas facile, mais la démarche choisie ici, avec des exemples simples au début, devrait aider le lecteur, même débutant.


La différence essentielle entre un éditeur traditionnel et Eclipse est que ce dernier va déjà nous montrer les erreurs de syntaxe et de code durant la frappe.


Simulation du matériel


En développant sous Windows et avec Eclipse pour Java, nous importerons toutes les bibliothèques Java dont nous aurons besoin pour notre travail. Même les bibliothèques spécifiques liées au Raspberry Pi et à son port GPIO seront considérées.


Lorsque nous ajouterons le logiciel pour un composant, comme un capteur de lumière, de mouvement ou de température, nous aurons évidemment un problème.


Le principe défini ici est le suivant, avec l’exemple d’un capteur de mouvement :


•Nous utiliserons un script Python sur le Raspberry Pi, beaucoup plus simple que le Java, pour vérifier que le circuit fonctionne.


•Nous compilerons le code Java de ce capteur dans Eclipse, avant de le transférer et de le tester sur le Raspberry Pi.


•Nous définirons du code de simulation de mouvement sous Windows pour vérifier notre code Java.


Le code Java des applications va vite correspondre à plus de 80 % du total. Le reste sera constitué de fonctions spécifiques aux composants GPIO du Raspberry Pi.


En simulant un mouvement détecté par le capteur, soit de manière aléatoire, soit toutes les n secondes, nous pourrons plus facilement vérifier notre code et aussi passer en mode débogage.


Une application qui s’attend à une température de -10 ou +40 degrés, ou à une intensité de lumière particulière, sera beaucoup plus facile à vérifier dans Eclipse, avec une simulation, que sur un Raspberry Pi avec de la glace ou un chalumeau !


Installation d’Eclipse


Pour le lecteur qui a déjà installé et utilisé Eclipse, un nouvel espace de travail suffira.


Nous trouverons les différentes versions sur le site https://www.eclipse.org/downloads/. L’outil est en anglais et nous nous y habituerons rapidement. Nous avons choisi la version Oxygen, la dernière en date au moment de l’écriture de ce livre.




TÉLÉCHARGEMENT Oxygen


[image: image]http://www.eclipse.org/downloads/packages/release/Oxygen/3





Pour Windows, nous avons sélectionné la version 64 bits (PC récents), mais des versions Linux ou macOS existent aussi. Téléchargez le fichier zippé contenant Eclipse IDE for Java Developers : eclipse-java-oxygen-3-win32-x86_64.zip.


Nous sélectionnerons sur notre ordinateur un disque suffisamment grand, voire rapide (SSD), pour y installer deux répertoires : un qui contiendra Eclipse et un autre de travail (le Workspace en anglais).


L’auteur a choisi le disque D: (pour ne pas encombrer le disque C: dédié à Windows 10) et les répertoires D:\Eclipse​Java​Oxygen et D:\Eclipse​Works​pace.


Si nous installions plus tard une version plus récente, nous choisirions alors d’autres répertoires. L’exportation de l’espace de travail et des projets pour cette nouvelle version est assez simple à effectuer.


Le plus commode est de dézipper eclipse-java-oxygen-3-win32-x86_64.zip dans D\: et de renommer le répertoire eclipse sur la racine en D:\​Eclipse​Java​Oxygen.


Dans ce répertoire, nous trouverons le fichier eclipse.exe, l’application Eclipse, dont nous créerons un lien sur le Bureau :
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Figure 1–1
Raccourci Eclipse du Bureau Windows





Avant de démarrer Eclipse pour la première fois, il nous faut installer Java.




Eclipse Photon June 2018, version 4.8.0


Lorsque le livre était pratiquement terminé, l’auteur a aussi installé cette dernière version. Il n’a pas rencontré de difficultés. L’installeur est différent et il faut choisir la version Eclipse IDE for Java Developers.


Si nous avons déjà un espace de travail (Workspace), il faut le sauvegarder, avant de l’utiliser pour cette nouvelle version. L’auteur fait régulièrement ces mises à jour, mais garde les anciennes versions et ses workspaces. Le nom de ces derniers contient la date et le nom de la version Eclipse comme Neon ou Oxygen3.





Installation du JDK de Java sous Windows


Le kit de développement pour Java, c’est le communément nommé JDK. Le Java SE Development Kit 8 est la version simplifiée et se trouve sur le site d’Oracle.




TÉLÉCHARGEMENT Java SE Development Kit 8


[image: image]http://www.oracle.com/​technetwork/​java/​javase/​downloads/​jdk8-​downloads-​2133151.html





Des versions plus récentes peuvent exister et ne devraient pas poser de difficultés. Il faut cependant qu’elles restent compatibles avec la version du Java que nous installerons sur le Raspberry Pi 3 B. Nous resterons donc avec la version 8 des deux côtés.


Nous avons téléchargé la version Windows 64 bits jdk-8u161-windows-x64.exe après avoir accepté l’accord de licence. Nous exécutons ce fichier à partir du répertoire de téléchargement :
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Figure 1–2
Installation du JDK – Démarrage





En cliquant sur Next, nous lançons l’installation :
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Figure 1–3
Installation du JDK – Option





Nous laissons toutes les options. Le code source est important pour retrouver la documentation des classes de la plate-forme Java.
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Figure 1–4
Installation du JDK – Répertoire





Si nous n’avons pas de restriction d’espace, il est préférable de laisser le JDK sur le disque C: principal.
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Figure 1–5
Installation du JDK – Fin de l’installation





L’installation est à présent terminée. Les outils de développement et le Runtime de Java sont installés et prêts pour être utilisés avec Eclipse.



Premier démarrage d’Eclipse


Nous lançons Eclipse avec le raccourci (figure 1-1).
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Figure 1–6
Eclipse – Premier démarrage





Nous cochons l’utilisation par défaut, car nous ne travaillerons pour l’instant qu’avec un seul espace de travail. Si nos projets deviennent conséquents, il sera préférable d’utiliser des espaces différents ; nous passerons alors de l’un à l’autre avec le menu File>Switch Workspace.


Le bouton Launch démarre Eclipse :
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Figure 1–7
Eclipse – Premier démarrage





Décochons en bas à gauche le Always show Welcome at start up si nous ne désirons plus revoir cette fenêtre au démarrage. Il sera cependant toujours possible de la réactiver ou de la fermer avec le menu Help>Welcome.


« Hello World en Java » sera notre premier projet Eclipse. Nous allons donc sélectionner File>New>Java Project dans le menu :
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Figure 1–8
Nouveau projet





Indiquons HelloWorld comme nom de projet.
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Figure 1–9
Le projet Eclipse HelloWorld





Nous laissons les autres options et continuons avec le bouton Finish.
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Figure 1–10
Un projet Eclipse sans source





Voici donc notre projet HelloWorld sous Eclipse, mais sans aucun code ou ressource.


Fichiers .java et .class


Les fichiers .java sont les sources des programmes Java.


Ils doivent suivre une syntaxe précise afin qu’ils puissent être compilés pour devenir des fichiers .class exécutables par une machine virtuelle Java.


Le JDK installé vient avec deux fichiers exécutables sous Windows, java.exe et javac.exe, qui sont respectivement la machine virtuelle pour exécuter les classes Java et le compilateur.




DÉFINITION Machine virtuelle


« La machine virtuelle Java (en anglais Java virtual machine, abréviation JVM) est un appareil informatique fictif qui exécute des programmes compilés sous forme de bytecode Java. » (Wikipedia)





En général, un PC Windows possède déjà un fichier binaire java.exe préinstallé quelque part. Plusieurs versions peuvent aussi cohabiter.


Comme Eclipse compile les sources de code Java et exécute ses classes à l’intérieur de l’outil, c’est donc totalement transparent. Nous ferons tout de même l’exercice pour compiler et exécuter hors d’Eclipse notre premier HelloWorld.


Dans cet ouvrage, nous ne compilerons jamais directement sur le Raspberry Pi 3 B. La version et les bibliothèques de l’environnement Java seront choisies et définies sous Eclipse pour permettre l’exécution plus tard sans soucis sur le Raspberry Pi 3 qui possède sa propre version de Java (la même que sur le PC).


Au contraire d’un code compilé avec des langages comme C++, nous n’avons pas besoin de recompiler le code ou d’utiliser un cross-compiler (compilateur croisé). La machine virtuelle Java préinstallée sur le Raspberry Pi exécute donc le code, appelé bytecode, des fichiers .class ou des bibliothèques .jar.


Lorsque nous aurons installé et eu accès au Raspberry Pi 3 B, nous pourrons vérifier les versions installées de la manière suivante :




pi@raspberrypi:~ $ java -version


java version "1.8.0_65"


Java(TM) SE Runtime Environment (build 1.8.0_65-b17)


Java HotSpot(TM) Client VM (build 25.65-b01, mixed mode)







pi@raspberrypi:~ $ javac -version


javac 1.8.0_65





Eh oui :


•Il n’y a pas de .exe sous Linux.


•Un compilateur javac existe, mais il ne sera pas directement utilisé ici.


Notepad++ et les fichiers texte


L’utilisation de Notepad++ sous Windows est impératif pour cet ouvrage. Il y a peut-être des alternatives que l’auteur n’a pas recherchées. Des outils comme le Bloc-notes ou WordPad sont inutilisables dans la plupart des cas.


Notepad++ va nous garantir que nos fichiers texte préparés et/ou modifiés sous Windows et/ou le Raspberry Pi fonctionneront dans tous les cas. Les fichiers des codes sources et des exercices de cet ouvrage sont disponibles dans des archives compressés .zip. Vous serez assuré que ces derniers fonctionnent correctement en utilisant Notepad++ pour la lecture ou la modification, avant utilisation dans Eclipse ou pour un transfert sur le Raspberry Pi.




TÉLÉCHARGEMENT Notepad++


[image: image]https://notepad-plus-plus.org/fr/





Installons-le par exemple dans le répertoire D:\Program Files (x86)\Notepad++, voire sur un autre disque ou le C: traditionnel.


Associez à Notepad++ les fichiers du type .java, .py (les fichiers Python), .txt (texte traditionnel), .sh (script shell Linux), .sql (fichiers de bas de données) ou encore .html.


Notepad++ propose une coloration syntaxique pour chaque langage défini par l’extension. C’est très pratique pour des fichiers .py, .sql ou .html et un plaisir de voir les instructions colorées correctement. Il est clair que, pour les fichiers .java, cela ne sera pas utile en principe, puisque nous travaillerons sous Eclipse. Néanmoins, visionner un fichier Java dans Notepad++ est vraiment propre et cela n’a rien à voir avec le Bloc-notes de Windows.


Les fichiers édités avec Notepad++ nous garantiront un contenu correct pour les caractères accentués, voire des langues étrangères. Les procédures de copier-coller seront aussi décrites plus loin dans cet ouvrage.



Notre première classe Java


Le code source Java doit suivre une syntaxe définie, sans quoi il ne sera pas compilable.


Voici donc notre classe Java HelloWorld dans un fichier HelloWorld.java préparé avec Notepad++, déposé par exemple dans D:\EclipseWorkspace et que nous intégrerons rapidement sous Eclipse :




// Projet Eclipse HelloWorld


//


import java.util.*;


public class HelloWorld {


   public static void main(String[] args) {


       Date aujourdhui = new Date();


       System.out.println("Hello world en Java: " + aujourdhui);


   }


}





Le nom du fichier doit commencer par une majuscule. Nous n’utiliserons que des majuscules et des minuscules, voire des chiffres, dans cet ouvrage. Ici, le W majuscule donne plus de lisibilité au nom du fichier et de la classe générée après compilation. Cette alternance de minuscules et majuscules sera utilisée pour les noms des variables et des méthodes.


Cette classe est plus que primitive : elle ne contient que l’entrée main() static. Nous ne créons pas d’objet, c’est-à-dire d’instance de cette classe. C’est un peu obscur pour l’instant, mais cela deviendra rapidement évident.


Pour avancer un peu, nous avons déjà ajouté une extension à notre HelloWorld : l’affichage de la date. Date et System sont des classes Java standards. La première nécessite qu’on l’importe avec l’instruction import. Le * indique qu’on va pouvoir considérer toutes les classes qui se trouvent dans la collection java.util du JDK (Java Development Kit), même si nous n’avons besoin que de la classe Date.


Le point d’entrée qu’utilisera la machine virtuelle de Java pour l’exécution de HelloWorld :




public static void main(String[] args) {





s’explique comme suit :


•public signifie visible et accessible pour tous.


•static veut dire « qui appartient à la classe » et non « à un objet de cette classe ».


•main() est le point d’entrée principal.


•String est une classe Java contenant une chaîne de caractères.


•String[] args est un tableau de paramètres passé par la machine virtuelle.


L’instruction :




Date aujourdhui = new Date();





se traduit quant à elle ainsi : création d’une variable objet, de type Date, avec l’instruction new appliquée sur le constructeur Date() de la classe Date.


Nous verrons bientôt comment, avec Eclipse, obtenir de la documentation sur les classes comme Date et System et leurs méthodes (fonctions) associées, ici out.println(). Cette dernière nous « imprime » le résultat à l’écran (sortie out). Ce que nous nommons « écran » sera la console d’Eclipse. Nous verrons aussi plus loin comment l’opérateur + va concaténer la chaîne de caractères Hello entre les guillemets "" avec une autre chaîne de caractères retournée par aujourdhui que le compilateur va convertir avec aujourdhui.toString().


Les chapitres suivants fourniront plus de détails sur la syntaxe et les instructions du langage Java.


Compilation et exécution sans Eclipse


Nous allons fixer les variables d’environnement PATH et JAVA_HOME de Windows, afin de nous assurer de travailler avec la bonne version de Java pour notre exemple.


Pour ajouter ou adapter ces deux variables d’environnement, nous utilisons la loupe de recherche de Windows et entrons Modifier les variables d’environnement système et cliquons finalement sur Variable d’environnement. Dans la partie Variables système, nous ajoutons et adaptons JAVA_HOME et PATH comme suit :




[image: image]


Figure 1–11
Windows PATH et JAVA_HOME





Avec Modifier, nous nous assurons que C:\Program Files\Java\jdk1.8.0_161\bin est bien en première position pour Path. Les deux variables doivent être positionnées à l’emplacement des fichiers binaires du JDK précédemment installé.


Pour vérifier ces variables, ainsi que le compilateur et la machine virtuelle, nous allons utiliser une console Windows CMD :
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Figure 1–12
Vérification du JDK avec une console CMD





Le paramètre -version nous permet de vérifier les versions. Aucune erreur n’est émise pour la compilation de HelloWorld.java. La commande java (.exe pas nécessaire) qui exécute HelloWorld n’a pas besoin de l’extension .class. Notre programme fonctionne correctement.


Compilation et exécution sous Eclipse


Précédemment, nous avons créé le projet HelloWorld sans classe Java. Nous allons maintenant y intégrer notre classe HelloWorld avant de le compiler et de l’exécuter.
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Figure 1–13
Eclipse – Ajouter une classe Java





Le menu File>New>Class nous permet de définir et d’ajouter une nouvelle classe à notre projet :
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Figure 1–14
Eclipse – Définition d’une nouvelle classe





Il suffit d’entrer HelloWorld comme Name, le nom de la classe. Nous cochons l’option public static void main() pour indiquer que cette classe aura un point d’entrée. Une classe Java doit contenir une entrée main() si nous voulons pouvoir l’exécuter avec une machine virtuelle ; si un fichier .java ne possède pas d’entrée main(), cela indique qu’il contient des classes (objets) utilisées par d’autres classes. C’est une bonne habitude de définir une entrée main() à des fins de test, même si cette classe ne sera jamais l’application principale.


Ici, nous n’utiliserons pas de package pour ces exercices simples (voir le chapitre consacré aux fichiers .jar).


Après Finish, le code suivant de cette nouvelle classe sera présenté dans la fenêtre d’édition d’Eclipse :
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Figure 1–15
Eclipse – Création d’une classe





Nous allons à présent copier le code du fichier HelloWorld.java créé précédemment avec Notepad++ et le coller dans la fenêtre d’édition :
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Figure 1–16
Notre classe HelloWorld





Avec la commande Run dans le menu, ou en pressant le bouton équivalent (rond vert – Play) dans la barre supérieure, le résultat Hello world en Java avec la date apparaîtra dans la fenêtre console inférieure.


Lors du tout premier Run, la fenêtre suivante devrait apparaître :
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Figure 1–17
Sauvegarde automatique sous Eclipse





Ici, nous avons coché le Always save et cette fenêtre n’apparaîtra plus. Le fichier HelloWorld.java sera automatiquement enregistré avant chaque Run.


Le même type de fenêtre apparaîtra aussi pour demander une confirmation pour d’autres sortes de fichiers, comme des fichiers de configuration. La décision est laissée au programmeur, qui peut toujours utiliser l’icône disquette pour une sauvegarde manuelle.


À la première utilisation, il est possible que la machine virtuelle soit bloquée par le Pare-feu de Windows. Il faut donc la débloquer :
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Figure 1–18
Pare-feu de Windows





Nous noterons ici la version javaw.exe (et non java.exe) qui n’a pas de console associée.


Une première astuce d’Eclipse


Remarquez les marques à gauche du code indiqué par Eclipse :
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Figure 1–19
Erreur dans le code Java





statica n’est pas une instruction Java, mais une faute de frappe. Elle sera soulignée et marquée à gauche. Ce code-ci, avant correction, ne pourra évidemment pas être exécuté.



Le répertoire projet HelloWorld
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Figure 1–20
Eclipse – Répertoire des fichiers .class





En naviguant dans l’espace de travail d’Eclipse pour ce projet, nous constatons la présence du répertoire bin. Il a été créé lors de la première compilation et contient le fichier HelloWorld.class.


Le Show In dans Eclipse, obtenu d’un clic-droit sur le nom d’un répertoire, est pratique :




[image: image]


Figure 1–21
Show In Windows Explorer





Il nous permet d’atteindre dans Windows Explorer le répertoire du projet et, ensuite, son sousrépertoire bin. Un Show In sur src irait aussi.


Si nous voulons exécuter HelloWorld sur un Raspberry Pi, il nous suffit de transférer le fichier .class avec WinSCP et de l’exécuter avec PuTTY. Nous y reviendrons.



Eclipse en UTF-8


Par défaut sous Windows, Eclipse utilise le jeu de caractères Cp1252. Il reconnaît l’anglais et la plupart des langues d’Europe de l’ouest. Cependant, si jusqu’ici nous avions utilisé des lettres accentuées, il faudrait les corriger.


Pour utiliser d’autres langues, il nous faut passer en UTF-8 (Universal character set Transformation Format). Il sera ainsi possible de programmer, par exemple, un Hello World en japonais.


Avant de continuer à utiliser Eclipse, nous allons le faire passer en UTF-8, dans son menu Windows>Preferences>General.


Commençons par l’espace de travail (Workspace) et faisons passer l’option Text File Encoding de Default (cp1252) à UTF-8 :
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Figure 1–22
Text file encoding – UTF-8





Un clic sur Apply ou Apply and Close est nécessaire.


Allons ensuite sous Content Types dans la même fenêtre :
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Figure 1–23
UTF-8 pour les options Java Class File et Text





Pour les options Java Class File et Text, nous devons entrer au clavier UTF-8 dans la case Default encoding.


Il faut à chaque fois cliquer sur Update avant Apply and Close.


N’oubliez pas l’entrée Java Properties File à modifier également. Ces fichiers sont parfois utilisés pour ajouter des textes dans une application multilangue.


Relançons la fenêtre du menu Windows>Preferences>General, pour vérifier que ces UTF-8 sont bien présents.


Résumé


Dans ce chapitre, nous avons installé les outils Java et Eclipse. Un premier exemple nous a permis de vérifier l’installation et de faire nos débuts avec Eclipse.



Exercices


1Créer une classe BonjourMonsieur, similaire à HelloWorld, mais avec un "Bonjour Monsieur" et sans aucune référence à la date. Vérifier la compilation et l’exécution à la fois sous Windows et sous Eclipse.


Nous constaterons que si nous commençons par effacer l’objet aujourd'hui de type Date, les erreurs seront indiquées à gauche. Si nous laissons l’instruction import, le code est compilé puis exécuté sans problème, même si un petit ! sur la ligne import nous indique qu’elle n’est pas nécessaire et peut donc être effacée.


2Jouer avec Notepad++ afin de se familiariser un peu plus avec cet outil. Éditer des fichiers de types différents, rechercher des textes ou mots-clés ou encore traiter correctement les tabulations ou les remplacer par des espaces. La recherche de mot-clés ou d’instructions, donc de texte, avec Ctrl-Maj-F, dans des sous-répertoires, est vraiment sans pareille.
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Aller plus loin avec Eclipse


Dans cette partie, toujours sous Windows, nous allons donner quelques informations supplémentaires sur les bases du langage Java, sa syntaxe et celle des fichiers .java. Ainsi, nous nous perfectionnerons avec un certain nombre de fonctionnalités d’Eclipse qui nous aideront par la suite.


Principe de développement


Le principe adopté dans ce livre est le suivant :


•Nous identifierons si nous travaillons sous Windows ou sur le Raspberry Pi 3 B.


•Nous allons avant tout déboguer notre code Java sous Windows, c’est-à-dire avec des System.out.println() ou alors pas à pas dans Eclipse en mode Debug.


•Nos applications exécutées sur le Raspberry Pi n’auront pas de sorties sur la console, c’est-à-dire aucun System.out.println(), sauf exceptionnellement.


•Toutes les classes Java impliquant le port GPIO auront été précédemment testées sous Eclipse avec des classes de test et de la simulation.


•Des scripts Python exécutés sur le Raspberry Pi vérifieront nos circuits électroniques connectés aux broches GPIO et correctement alimentés.



Pas à pas sous Eclipse


Comme pour notre projet HelloWorld, nous devons créer dans Eclipse un nouveau projet PasAPas et sa classe éponyme :


•Dans le menu File>New>JavaProject, entrer le nom PasAPas.


•Procédez de même dans le menu File>New>Class. Ce sera notre première classe Java, très simplifiée, pour faire nos premiers pas avec le débogueur d’Eclipse.


Plus loin dans cet ouvrage, nous montrerons comment déboguer à distance. Notre code sera exécuté pas à pas sur le Raspberry Pi 3 et depuis Eclipse (Remote Debug).


En anglais ou en français


Le langage Java utilise des termes anglais. Nous en utiliserons parfois aussi pour les variables, mais avec des commentaires en français le plus souvent.


Ce sera le cas de la plupart des exemples de ce livre : les termes anglais sont souvent plus courts et il vaut mieux éviter d’employer des accents dans des variables. L’auteur a aussi choisi par simplicité quelques messages en anglais venant sur la console.


Notre classe PasAPas


Voici à présent notre classe PasAPas que nous allons expliquer et utiliser pour notre démonstration de débogage :




// Projet Eclipse PasAPas


// Class PasAPas pour jouer avec le débogueur d'Eclipse


//


public class PasAPas {


  static public boolean withPrint = false;


  static public boolean isTarget   = true;


  public static void main(String[] args) {


    if (System.getProperty​("os.name")​.startsWith​("Windows")) {


        System.out.println("PasAPas - Nous sommes sous Windows ");


        withPrint = true;


        isTarget = false;    // Pas le Raspberry Pi, mais Windows


    }


    System.out.println("Nos paramètres withPrint et isTarget: " +


                       withPrint + " " + isTarget);


  }


}







Project Explorer ou Package Explorer ?


Sur la figure 2-1, nous avons à gauche le mode Package Explorer de présentation pour les classes et paquets. Le mode Project Explorer va aussi très bien. Le lecteur choisira.


Bien qu’il soit possible d’avoir les deux actifs, ce n’est pas vraiment utile. Nous pouvons les fermer à tout instant et les réactiver, comme d’autres fenêtres d’ailleurs, avec le menu Window>Show View.


Avec un autre menu, Window>Perspective>Open Perspective, nous pourrions choisir une autre perspective de travail. Nous reviendrons sur le mode Debug et nous laisserons le lecteur jouer et choisir ces différentes présentations à l'écran.





Le bouton Run As sert à exécuter la classe PasAPas :
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Figure 2–1
Exécuter PasAPas





Nous remarquerons nos deux projets à gauche et la classe PasAPas que nous avons sélectionnée. Eclipse sait déjà que HelloWorld peut être exécutée, mais rien de la nouvelle classe. Nous devons lui indiquer le Run As avec Java Application.


Le résultat apparaîtra dans la fenêtre console d’Eclipse :




PasAPas - Nous sommes sous Windows


Nos paramètres withPrint et isTarget: true false





La variable isTarget sera utilisée tout au long de l’ouvrage pour indiquer si nous sommes sur le Raspberry Pi 3, c’est-à-dire isTarget=true (vrai). Cela nous permettra, par exemple en présence de code utilisant le port GPIO, de ne pas l’exécuter sous Windows.


La variable withPrint avec la valeur true sera utile pour montrer des messages pendant l’exécution, aussi sur le Raspberry Pi dans les premières phases de tests.


Nous allons à présent passer un instant sur le code Java qui précède et sa syntaxe :




// Projet Eclipse PasAPas


// Class PasAPas pour jouer avec le débogueur d'Eclipse


//





Les deux barres obliques // délimitent de la documentation et aèrent le code. Tout ce qui vient après ces symboles sur la ligne est ignoré par le compilateur java (javac.exe).


Nous pouvons aussi ajouter un commentaire après l’instruction :




isTarget = false;    // Pas le Raspberry Pi, mais Windows





Nous verrons plus loin (avec javadoc) une autre manière de documenter le code :




/*


 * Class PasAPas pour jouer avec le débogueur d'Eclipse


 */





Dès qu’un /* est défini, Eclipse (donc le compilateur), cherche un */ de fin de documentation, qui peut être beaucoup plus loin dans le code. Eclipse ajoute aussi l’indentation à partir de la deuxième ligne de commentaire.


À présent, nous passons à la déclaration de la classe. PasAPas doit avoir le même nom orthographié que le fichier PasAPas.java. Sinon le compilateur va l’indiquer.


Eclipse permet de renommer une classe. Cela se nomme Refactor : cliquez-droit sur le nom du fichier et sélectionner Refactor dans le menu contextuel.




public class PasAPas {


   static public boolean withPrint = false;


   static public boolean isTarget  = true;





Les deux variables withPrint et isTarget sont public et static. Elles sont complètement ouvertes et accessibles de l’extérieur sans instance d’objet (exemple d’accès : PasAPas.isTarget).


La variable withPrint sera utilisée par exemple dans des classes de test de classe pour les composants du port GPIO, afin de les vérifier dans un mode console avec PuTTY.




public static void main(String[] args) {


  //...


}





La méthode main() est toujours public static void. Comme toutes les méthodes, elle consiste en une déclaration et un corps entre les accolades. Comme nous le verrons dans le chapitre sur nos débuts en Java, c’est un choix de présentation de ne pas mettre la première accolade sur la ligne suivante. L’indentation est importante.




  public static void main(String[] args) {


    if (System.getProperty​("os.name")​.startsWith​("Windows")) {


        System.out.println("PasAPas - Nous sommes sous Windows ");


        withPrint = true;


        isTarget = false;    // Pas le Raspberry, mais Windows


    }


  }





Nous remarquons l’indentation pour un bon alignement du bloc de l’instruction conditionnelle if (si).


Cela se complique à présent. La classe System possède un certain nombre de méthodes, dont getProperty(). Il est possible de lire le nom du système d’exploitation en utilisant le paramètre "os.name". La méthode getProperty() doit recevoir un String comme paramètre (entre les parenthèses), c’est-à-dire une chaîne de caractères entre guillemets (" "). Nous aurions pu aussi déclarer une variable String et la passer à la méthode :




   String osName = "os.name";


   if (System.getProperty​(osName)​...





Notons la forme de la variable osName, une notation propre, avec une lettre minuscule au début pour la différencier d’une classe, une majuscule au bon endroit (pour séparer les mots) et sans caractères « exotiques », comme – , _ ou des lettres accentuées.




   if (System.getProperty​("os.name")​.startsWith​("Windows")) {





Donc, getProperty() nous retourne un objet de la classe String qui elle-même possède une méthode startsWith(). Cette dernière nous indique, par vrai (true) ou faux (false), si la chaîne commence par "Windows". startsWith() et endsWith() (respectivement « commence par » et « finit par ») sont de ces méthodes de la classe String que nous rencontrerons partout.


L’instruction if () contient un bloc exécuté si le résultat est vrai. Nous pourrons alors mettre par exemple la variable à false (faux) si nous ne sommes pas sur le Raspberry Pi.




System.out.println("Nos paramètres withPrint et isTarget: " +


                    withPrint + " " + isTarget);





Le System.out correspond à une sortie sur la console, affichant quatre chaînes de caractères qui sont concaténées avec l’opérateur +. Le ln de println ajoute un retour de ligne en fin d’opération.


Sous Eclipse, en naviguant dans le code source avec la souris et en s’arrêtant ici sur la méthode println, nous obtenons sa documentation :
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Figure 2–2
Documentation de println





Nous pourrons même aller plus loin en cliquant sur String dans cette fenêtre pour obtenir la documentation en ligne :
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Figure 2–3
Java – Documentation en ligne





Si cela ne fonctionne pas, cela indique que nous n’avons pas d’accès à Internet ou que l’adresse chez Oracle n’est pas renseignée correctement.


Pour vérifier ou installer la documentation en ligne, il faut se rendre sur Window>​Preferences>​Java>​Installed JREs, puis cliquer sur la version installée et sur le bouton Edit :




[image: image]


Figure 2–4
Documentation en ligne chez Oracle





Il faut sélectionner tous les fichiers .jar (les bibliothèques Java) avant de cliquer sur le bouton Javadoc Location. L’adresse doit être https://​docs​.oracle​.com/​javase/​8/​docs/​api/.


Il vous est également possible de télécharger la documentation sur le PC, pour avoir un accès sans Internet.


Lors de l’entrée de texte, par exemple System.get, une fenêtre s’affiche qui propose de choisir comment compléter l’instruction :
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Figure 2–5
Choix de la méthode lors de l’entrée du texte





Nous nous déplaçons alors dans la fenêtre des get, puis dans la seconde, pour y retrouver notre os.name. À gauche, nous découvrons deux petites croix rouges indiquant des erreurs, car le code n’est pas encore complet à ce moment précis.


Eclipse et indentation


Plus loin dans cet ouvrage, nous reparlerons du formatage de notre code. Nous allons cependant déjà mentionner ici les outils de formatage d’Eclipse et des configurations possibles. Le plus important reste le tabulateur (tab) que nous devons absolument configurer.


Ce qu’il faut comprendre, dans le cas où nous avons déjà entré la ligne




if (System.getProperty​("os.name")​.startsWith​("Windows")) {





c’est que, quand nous pressons la touche Entrée, nous obtenons automatiquement une indentation relative à la classe, à la méthode main() et à l’instruction conditionnelle if () :




  public static void main(String[] args) {


    if (System.getProperty​("os.name")​.startsWith​("Windows")) {


      (ici)


    }





Le (ici) indique que la position courante du curseur.


Le nombre d’espaces par tabulation est réglable. La configuration dans Eclipse se fait à partir du menu Window>Preferences>Java>Code Style>Formatter et le bouton Edit.
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Figure 2–6
Profil d’édition Java sous Eclipse, nommé LeLivre. La tabulation est ici spécifiée de deux espaces.





Nous allons à présent parler de deux outils plus que pratiques :
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Figure 2–7
Tabulations, espaces et bloc





Les deux boutons signalés sur la figure 2-7 sont activés par un clic sur leurs icônes. Celui de gauche sert à travailler sur un bloc, ici en bleu, que nous sélectionnons avec la souris (par exemple pour l’effacer). Le bouton de droite active l’affichage des tabulations, des espaces et des fins de ligne.




Que de fenêtres et où sont-elles ?


Eclipse propose beaucoup de fenêtres, qu’il est parfois plus confortable de masquer. Sur la figure 2-7, nous avons fermé à gauche l’explorateur de projet. Pour le faire revenir, il faudra utiliser le menu Window>Show View>Project Explorer. Eclipse nous permet de déplacer nos fenêtres en fonction de nos désirs et de la grandeur de notre écran. En principe, on travaille avec le Project Explorer à gauche, notre code source Java à droite et une petite place en bas pour la Console. Nous agrandissons ou diminuons les fenêtres suivant la définition de notre écran. Un écran large, voire 4K, est l’idéal. En cas de mauvaises manipulations, un Window>​Perspective>​Reset Perspective... va nous aider. Ensuite, nous fermerons toutes les fenêtres que nous pensons inutiles (exemple Task list) et que nous pourrons toujours réactiver avec Window>Show View.
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