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      Avant-propos
   


    
L'ou­vrage que vous tenez entre les mains repré­sente un ins­tan­tané de l'évo­lu­tion du SDK que propose Apple pour déve­lop­per des appli­ca­tions pour iPhone et iPad. Afin de suivre les nou­veau­tés qui appa­raissent depuis la parution, le contenu de l'ou­vrage est complété par le site :


    
      http://alltouches.com


    
Ce site contient :


    

      	des mises à jour ou des pré­ci­sions pour les infor­ma­tions décrites dans cet ouvrage ;

      	des projets cor­res­pon­dant aux quelques exemples qui ne pro­viennent pas du SDK d'Apple ;

      	un accès direct aux éléments réfé­ren­cés par une séquence de la forme [i-j]. La réfé­rence à ces éléments est actua­li­sée régu­liè­re­ment.

    


    
D'autre part, les quelques cen­taines de pages qui suivent sont bien insuf­fi­santes pour traiter un sujet aussi vaste et pas­sion­nant que la création d'ap­pli­ca­tions pour iPhone OS ! Il a fallu faire des choix parfois dou­lou­reux : laisser de côté des idées, des plans, des schémas, des lignes déjà écrites, n'est jamais facile. Cette sélec­tion est pourtant indis­pen­sable. Au cours d'un entre­tien avec un jour­na­liste qui lui deman­dait de quel produit il était le plus fier, Steve Jobs a eu cette réponse inat­ten­due mais tel­le­ment juste : « En fait, je suis surtout fier d'avoir pu éviter de sortir certains produits ! ». Les thèmes déve­lop­pés essaient donc de donner l'es­sen­tiel et surtout les bonnes bases pour pouvoir aborder ensuite n'im­porte quel autre domaine.


    
L'ou­vrage est ainsi organisé en cinq grandes parties :


    

      	La première décrit l'ins­tal­la­tion du SDK et les outils dis­po­nibles.

      	La deuxième détaille les briques de base et les assem­blages fon­da­men­taux.

      	La troi­sième explore les rouages du fonc­tion­ne­ment d'iPhone OS.

      	La qua­trième définit les éléments de l'in­ter­face uti­li­sa­teur.

      	La cin­quième parcourt les dif­fé­rentes pos­si­bi­li­tés acces­sibles par un péri­phé­rique tactile.

    


    
La lecture séquen­tielle de ces parties est conseillée pour acquérir pro­gres­si­ve­ment les connais­sances néces­saires. Cepen­dant, certains éléments peuvent être survolés en première lecture et appro­fon­dis, si besoin, dans un second temps.


    
Enfin, deux annexes avec des contenus trans­ver­saux com­plètent le parcours général :


    

      	L'annexe A explique les notions essen­tielles de la pro­gram­ma­tion objet.

      	L'annexe B donne des conseils pour la mise au point des appli­ca­tions.

    


    
Nous sou­hai­tons qu'en explo­rant tous ces cha­pitres, le lecteur ren­contre autant de plaisir que nous à pouvoir donner vie à ses idées sur les écrans tactiles d'Apple !
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        Partie 1

      
      	
        Pour commencer...

      
    

  



Avant de pouvoir écrire les pre­mières lignes de code, il faut pouvoir ins­tal­ler les outils de déve­lop­pe­ment et com­prendre les quelques rudi­ments de leur fonc­tion­ne­ment.

Cette partie explique la confi­gu­ra­tion néces­saire pour pouvoir mettre en œuvre le fameux SDK. Elle détaille aussi comment retrou­ver régu­liè­re­ment des infor­ma­tions et propose une visite de Xcode et d'In­ter­face Builder qui consti­tuent le cadre de la suite de cet ouvrage.


  Chapitre 1. Ce qu'il faut savoir sur le SDK



  Chapitre 2. Les outils de déve­lop­pe­ment sur iPhone OS





  
    Chapitre 1
  




  Ce qu'il faut savoir
 sur le SDK




            Objectif

            La pro­gram­ma­tion d'ap­pli­ca­tions pour des péri­phé­riques tactiles Apple ne peut se faire qu'en uti­li­sant le SDK iPhone OS. Ce chapitre explique quels sont les éléments indis­pen­sables pour se procurer et faire fonc­tion­ner ce SDK.

            Le dis­po­si­tif le plus acces­sible pour tester une appli­ca­tion pour iPhone OS est le simu­la­teur qui fonc­tionne sur la confi­gu­ra­tion de déve­lop­pe­ment. Cepen­dant, si l'ap­pli­ca­tion est destinée à être déployée sur des péri­phé­riques phy­siques, il faut alors gérer les notions de cer­ti­fi­cats et de profils de pro­vi­sion­ne­ment.

            Ce chapitre décrit aussi l'ac­com­pa­gne­ment dis­po­nible pour déve­lop­per sur iPhone OS et fournit une vision d'en­semble de l'ar­chi­tec­ture de ce système et l'or­ga­ni­sa­tion de cet ouvrage.

          


1.1.  Prérequis


1.1.1.  Configuration

Pour ins­tal­ler le SDK iPhone OS qui permet de créer des appli­ca­tions pour iPhone ou iPad, vous devez disposer d'une confi­gu­ra­tion avec Mac OS X 10.6. Pour visua­li­ser l'in­té­gra­lité de l'écran de l'iPad en taille réelle dans le simu­la­teur, vous devez disposer d'un écran d'au moins 17". Cette confi­gu­ra­tion est recom­man­dée pour la mise au point des détails de l'in­ter­face uti­li­sa­teur. Si votre écran est de dimen­sion infé­rieure, vous pouvez néan­moins afficher l'écran en taille réduite ou faire défiler l'écran de l'iPad dans une fenêtre.


1.1.2.  Enregistrement auprès d'Apple

Pour télé­char­ger le SDK, vous devez vous enre­gis­trer auprès d'Apple sur le site :

[1-1] http://developer.apple.com/programs/register/

Le premier niveau d'en­re­gis­tre­ment est gratuit. Il vous permet de créer des appli­ca­tions iPhone OS et de les tester dans le simu­la­teur. Si vous êtes déjà enre­gis­tré auprès d'Apple (par exemple pour des achats iTunes ou Apple Store) nous vous conseillons de conser­ver le même Apple ID. Si vous sou­hai­tez ensuite sous­crire à un niveau supé­rieur, le pro­ces­sus d'achat est ainsi plus facile.
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    Fig. 1.1  Enregistrement auprès d'Apple

  



Les dif­fé­rentes infor­ma­tions sur votre compte sont acces­sibles sur le portail Member Center :

[1-2] http://developer.apple.com/membercenter/


                	Le lien Your Account (figure 1.2, repère 1) vous permet de mettre à jour ces infor­ma­tions.

                	Le lien Programs & Add-Ons (repère 2) permet de gérer les options de votre pro­gramme. Il est en par­ti­cu­lier possible de trans­fé­rer des éléments d'un compte à un autre. On peut, par exemple, imaginer qu'un res­pon­sable a souscrit à un pro­gramme mais ne déve­loppe pas lui-même. Il dispose alors de « tickets » qu'il peut trans­fé­rer ici à un déve­lop­peur de son équipe.

                	Le lien sur iPhone Dev Center (repère 3) donne accès au portail prin­ci­pal des res­sources pour déve­lop­per sur iPhone OS :

              

[1-3] http://developer.apple.com/iphone/

L'accès au télé­char­ge­ment du SDK se trouve sur ce portail iPhone Dev Center.
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    Fig. 1.2  Le site de membre d'un programme

  




1.2.  Création d'un certificat

Une appli­ca­tion ne peut tourner sur un péri­phé­rique physique (iPhone, iPod ou iPad) que si elle est signée avec votre clé per­son­nelle, cer­ti­fiée par Apple. Ce pro­ces­sus de cer­ti­fi­ca­tion (puis de l'éven­tuelle vali­da­tion de votre appli­ca­tion sur l'App Store) néces­site l'adhé­sion au iPhone Deve­lo­per Program d'Apple.

Pour un par­ti­cu­lier ou une société qui ne gère qu'un nombre réduit de péri­phé­riques (moins d'une centaine), le pro­gramme par défaut est suf­fi­sant. Il coûte 79 ? par an, au moment de la rédac­tion de cet ouvrage.

La gestion des cer­ti­fi­cats est réalisée sur le site iPhone Pro­vi­sio­ning Portal. Ce site est acces­sible par :


              	le lien repère 4 de la figure 1.2 ;

              	[1-4] http://developer.apple.com/iphone/manage/overview/index.action


            

La des­crip­tion détaillée des dif­fé­rents iden­ti­fiants est décrite par le document Program User Guide. Ce document est acces­sible par le lien repère 1 de la figure 1.3.
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    Fig. 1.3  Le portail de provisionnement

  



L'ins­tal­la­tion d'un cer­ti­fi­cat sur votre confi­gu­ra­tion de déve­lop­pe­ment néces­site trois grandes étapes :


              	La géné­ra­tion d'un couple clé privée/clé publique avec le menu Trous­seau d'accès > Assis­tant de cer­ti­fi­ca­tion de l'ap­pli­ca­tion Trous­seau d'accès (dans le réper­toire Applications/Utilitaires). Les options de géné­ra­tion sont décrites par la figure 1.4. Cette opé­ra­tion crée un fichier de type certSigningRequest.
	[image: Vautherin_chap_1Fig4.eps]


Fig. 1.4  Génération de clés






              	La cer­ti­fi­ca­tion de cette clé et la géné­ra­tion du cer­ti­fi­cat associé par la section Cer­ti­fi­cates du portail de pro­vi­sion­ne­ment (repère 2 de la figure 1.3). La cer­ti­fi­ca­tion est réalisée par la sou­mis­sion du fichier certSigningRequest, créé à l'étape pré­cé­dente. Après vali­da­tion, le cer­ti­fi­cat est dis­po­nible sur le portail et peut être télé­chargé sur la confi­gu­ra­tion de déve­lop­pe­ment.

              	L'ou­ver­ture, avec l'ap­pli­ca­tion Trous­seau d'accès, du cer­ti­fi­cat télé­chargé procède à son ins­tal­la­tion dans la confi­gu­ra­tion de déve­lop­pe­ment.
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Fig. 1.5  Le certificat et la clé privée dans le trousseau d'accès






            

L'en­semble du pro­ces­sus est illustré par la figure 1.6.
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    Fig. 1.6  Création et installation du certificat

  




1.3.  Profils de provisionnement

Le support de la signa­ture d'une appli­ca­tion est un profil de pro­vi­sion­ne­ment :


              	soit pour le déve­lop­pe­ment. Ce profil permet de lancer l'ap­pli­ca­tion sur les péri­phé­riques dont les iden­ti­fiants sont inscrits au moment de sa création ;

              	soit pour la dis­tri­bu­tion. Ce profil permet la dis­tri­bu­tion de l'ap­pli­ca­tion par l'App Store.

            

Tout comme le cer­ti­fi­cat, les profils sont gérés par le portail de pro­vi­sion­ne­ment.

Pour tester votre appli­ca­tion sur votre péri­phé­rique, il faut donc créer un profil conte­nant les iden­ti­fiants de l'ap­pli­ca­tion et du péri­phé­rique.


1.3.  Identifiant de l'application

L'iden­ti­fiant de l'ap­pli­ca­tion est géné­ra­le­ment consti­tué à partir de l'iden­ti­fi­ca­tion de votre domaine Internet. Les consti­tuants du domaine sont assem­blés en suivant l'ordre de recherche des serveurs de noms. Cet assem­blage cor­res­pond à l'ordre opposé de l'URL du domaine. Ainsi, par exemple, pour le domaine clubiphone.asso.fr, l'iden­ti­fiant de l'ap­pli­ca­tion commence par fr.asso.clubiphone. La des­crip­tion d'un iden­ti­fiant d'ap­pli­ca­tion peut être géné­rique ou unique :


                	Une des­crip­tion géné­rique est terminée par la séquence .*. Elle permet de se servir d'un même profil pour plu­sieurs appli­ca­tions. L'iden­ti­fiant de l'ap­pli­ca­tion figurant dans le bundle que nous abor­de­rons au chapitre 8 doit bien évi­dem­ment rem­pla­cer le carac­tère * par un nom spé­ci­fique.

                	Une des­crip­tion unique inclut le nom de l'ap­pli­ca­tion. Ce type de des­crip­tion est indis­pen­sable si l'ap­pli­ca­tion souhaite mettre en œuvre les Push Noti­fi­ca­tions que nous abor­de­rons au chapitre 14.

              


1.3.  Identifiant du périphérique

L'iden­ti­fiant d'un péri­phé­rique est dis­po­nible dans iTunes en cliquant sur l'in­ti­tulé Numéro de série de l'écran Résumé de ce péri­phé­rique. L'in­ti­tulé devient alors Iden­ti­fiant (UDID) et la chaîne de carac­tères cor­res­pon­dante est celle qui doit être fournie pour désigner le péri­phé­rique. La chaîne de carac­tères peut être copiée dans le presse-papiers pour faci­li­ter la saisie.


1.3.  Création et installation

L'as­sis­tant de géné­ra­tion de profil, acces­sible par le lien cor­res­pon­dant sur le portail de pro­vi­sion­ne­ment (repère 3 de la figure 1.3), prend en charge la création du fichier conte­nant le profil.

En ouvrant ce fichier avec Xcode, il est installé sur la confi­gu­ra­tion de déve­lop­pe­ment. L'or­ga­ni­seur de Xcode (décrit au paragraphe 2.2.7) permet de gérer les dif­fé­rents profils pour un péri­phé­rique.


  
    
      
        	
          [image: Vautherin_chap_1Fig7.eps]
        
      

    

    Fig. 1.7  Installation d'un profil de développement

  



Le profil de pro­vi­sion­ne­ment pour la dis­tri­bu­tion suit la même logique. Le mode de dis­tri­bu­tion intitulé « Ad Hoc » permet en outre de dis­tri­buer et de faire fonc­tion­ner l'ap­pli­ca­tion sur des péri­phé­riques non connec­tés à la confi­gu­ra­tion de déve­lop­pe­ment et sans passer par l'App Store. Ce mode de dis­tri­bu­tion limité est nor­ma­le­ment réservé aux tests d'une appli­ca­tion avant son lan­ce­ment public.


1.4.  Accompagnement


1.4.1.  Forums

Être membre d'un pro­gramme déve­lop­peur Apple permet aussi d'ac­cé­der aux forums de dis­cus­sion Apple. Ces forums sont par­ti­cu­liè­re­ment inté­res­sants parce que des ingé­nieurs d'Apple y par­ti­cipent et répondent souvent à des ques­tions qui ne sont pas toujours abordées dans la docu­men­ta­tion. Atten­tion tou­te­fois, ces ingé­nieurs n'ont pas le droit d'évo­quer des éléments qui n'ont pas encore été révélés publi­que­ment.

Les forums d'Apple sont en anglais. Si vous sou­hai­tez discuter dans votre langue avec d'autres déve­lop­peurs, voici une liste (non exhaus­tive !) de forums en français consa­crés au déve­lop­pe­ment sur iPhone OS :

[1-5] http://www.belgium-iphone.com/forum/viewforum.php?f=25

[1-6] http://www.cocoa.fr/

[1-7] http://www.developpez.net/forums/f1304/systemes/autres-systemes/mobiles/iphone/

[1-8] http://www.iphonefr.com/viewforum.php?id=48

[1-9] http://forum.iphonezine.fr/viewforum.php?id=15

[1-10] http://www.ipup.fr/forum/index.php

[1-11] http://forum.mac4ever.com/apple.html

[1-12] http://forum.macbidouille.com/index.php?showforum=39

[1-13] http://forum.macfr.com/index.php?showforum=27

[1-14] http://forum.pommedev.com/index.php


1.4.2.  Support technique

L'adhé­sion payante aux pro­grammes déve­lop­peur permet aussi de béné­fi­cier de deux « tickets de support » par an. Un ticket de support permet de contac­ter l'équipe d'in­gé­nieurs de support au déve­lop­pe­ment d'Apple pour résoudre un problème par­ti­cu­lier. Cet échange s'ef­fec­tue géné­ra­le­ment par courriel, compte tenu du décalage horaire entre la France et Cuper­tino !


1.4.3.  Pré-versions

Dans le cadre de l'adhé­sion payante, Apple donne accès aux pré-versions d'iPhone OS. Une pré-version permet de com­men­cer à déve­lop­per pour un système qui n'est pas encore dis­tri­bué par Apple et, avec un peu de chance, d'être présent sur l'App Store au moment de l'in­tro­duc­tion de ce nouveau système.


1.5.  Architecture d'iPhone OS

iPhone OS est composé de couches qui reposent les unes sur les autres :


              	La couche la plus basse est Core OS. Il s'agit d'un noyau UNIX qui propose les services fon­da­men­taux du système d'ex­ploi­ta­tion : gestion de la mémoire, lan­ce­ment des pro­ces­sus, accès réseau, etc. Les fonc­tions POSIX per­mettent de mettre en œuvre ces services.

              	La couche Core Services est consti­tuée de biblio­thèques, acces­sibles en C, qui implé­mentent une abs­trac­tion des struc­tures essen­tielles telles que les chaînes de carac­tères, les dates, etc. et des services tels que les com­mu­ni­ca­tions réseau, la sécurité.

              	La couche Media Layer donne accès aux affi­chages gra­phiques, à l'audio et à la vidéo. Cette couche comprend le moteur gra­phique Core Graphics, la tech­no­lo­gie OpenGL, équi­valent audio de cette tech­no­lo­gie, nommé OpenAL.

              	La couche supé­rieure est Cocoa Touch qui ras­semble des classes Objective-C orga­ni­sées en dif­fé­rents fra­me­works[1].
	Le fra­me­work fon­da­men­tal est Foun­da­tion. Il définit les objets de base tels que NSObject et les struc­tures comme les col­lec­tions, et les chaînes de carac­tères.

	Le fra­me­work le plus impor­tant est UIKit. Il définit l'in­ter­face uti­li­sa­teur et la très grande majorité des éléments présents sur l'écran du péri­phé­rique pro­viennent de ce fra­me­work.

	Des fra­me­works dédiés à des aspects spé­ci­fiques (car­to­gra­phie, com­mu­ni­ca­tions entre joueurs, etc.) com­plètent Cocoa Touch.





            

Cet ouvrage se concentre sur la mise en œuvre de Cocoa Touch parce que les classes qui com­posent cette couche pro­posent un niveau d'abs­trac­tion qui rend très facile l'as­sem­blage des dif­fé­rents éléments. Il est toujours possible de com­plé­ter cette mise en œuvre par des appels aux couches infé­rieures.
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    Fig. 1.8  L'architecture d'iPhone OS

  



Les conven­tions retenues par Apple uti­lisent les deux pre­mières lettres d'un nom pour désigner le fra­me­work auquel appar­tient l'élé­ment. Ainsi :


              	
CF... désigne un élément de Core Foun­da­tion.

              	
CG... Core Graphics.

              	
UI... User Inter­face.

              	
NS... Foun­da­tion (NeXTSTEP était le nom du premier fra­me­work défi­nis­sant ces objets).

              	Etc.

            





Notes

[1]  La notion de fra­me­work est détaillée en fin d'annexe 1.








  
    Chapitre 2
  




  Les outils de développement sur iPhone OS




            Objectif

            Ce chapitre décrit comment mettre en œuvre les deux outils fon­da­men­taux du déve­lop­pe­ment sur iPhone OS :
– Xcode qui est l'en­vi­ron­ne­ment de déve­lop­pe­ment intégré ;
– le simu­la­teur qui permet de lancer l'ap­pli­ca­tion iPhone OS sur sa machine de déve­lop­pe­ment ;
– Interface Builder qui est l'outil pour dessiner l'in­ter­face uti­li­sa­teur.

            La bonne com­pré­hen­sion de ce chapitre est indis­pen­sable pour utiliser les exemples cités dans cet ouvrage et pour créer votre propre appli­ca­tion.

          


2.1.  Installation des outils

Les outils de déve­lop­pe­ment pour iPhone OS sont ras­sem­blés dans une image de volume de disque à télé­char­ger dans la section Down­loads du site prin­ci­pal :

[2-1] http://developer.apple.com/iphone/

Cette image présente une taille de plu­sieurs giga­oc­tets. Il faut donc prévoir une connexion Internet stable et de bonne qualité pour réaliser ce télé­char­ge­ment.

Une fois l'image télé­char­gée, elle apparaît comme un volume sur le bureau du Mac et l'as­sis­tant d'ins­tal­la­tion se lance. Il faut com­men­cer par valider les dif­fé­rents contrats d'uti­li­sa­tion des outils Apple puis sélec­tion­ner les options d'ins­tal­la­tion. Ces options, illus­trées par la figure 2.1, sont essen­tiel­le­ment consti­tuées par le choix des versions d'iPhone OS pour les­quelles vous sou­hai­tez pouvoir déve­lop­per. Cet ouvrage met en œuvre la sélec­tion par défaut. Les versions 3.1 et 3.2 sont néces­saires pour suivre les exemples proposés.

Une autre option, moins visible, permet d'ins­tal­ler simul­ta­né­ment plu­sieurs versions des outils sur la machine de déve­lop­pe­ment. Par défaut, les outils sont ins­tal­lés dans le réper­toire /Developer sur le volume de démar­rage. Cette version cor­res­pond habi­tuel­le­ment à une version fina­li­sée des outils, indis­pen­sable pour pouvoir publier des appli­ca­tions sur l'App Store.

Il arrive cepen­dant que des versions pré­li­mi­naires des outils soient pro­po­sées en test aux déve­lop­peurs. Il s'agit, par exemple, de déve­lop­per des appli­ca­tions pour une future version d'iPhone OS. Puisque ces outils ne sont pas fina­li­sés, il n'est pas possible de les utiliser pour construire une appli­ca­tion destinée à l'App Store. C'est pourquoi on installe géné­ra­le­ment les versions pré­li­mi­naires dans un réper­toire spé­ci­fique (nommé, par exemple /DeveloperBeta). Le choix du réper­toire d'ins­tal­la­tion des outils est réalisé en cliquant sur l'image de dossier appa­rais­sant avec les options d'ins­tal­la­tion.
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    Fig. 2.1  Options d'installation des outils

  



L'ap­pli­ca­tion Xcode consti­tue le point d'entrée prin­ci­pal pour mettre au point une appli­ca­tion pour iPhone OS. Cette appli­ca­tion est située dans le réper­toire Developer/Applications. Nous vous conseillons de placer un rac­courci vers cette appli­ca­tion dans le Dock de Mac OS X afin d'y accéder immé­dia­te­ment.

Xcode permet ensuite de naviguer au travers de tous les autres com­po­sants.


2.2.  Xcode


2.2.1.  Présentation

Xcode est un envi­ron­ne­ment de déve­lop­pe­ment intégré (IDE) qui permet au déve­lop­peur de se concen­trer sur la rédac­tion et la mise au point du code de son appli­ca­tion.

La mise en œuvre de Xcode se compose de trois éléments prin­ci­paux :


                	le projet ;

                	la docu­men­ta­tion ;

                	l'or­ga­ni­seur.

              

La docu­men­ta­tion regroupe des guides d'uti­li­sa­tion, les infor­ma­tions de réfé­rence de toutes les classes et des exemples de code. Le projet est l'unité de pro­duc­tion d'une appli­ca­tion. L'or­ga­ni­seur cen­tra­lise les infor­ma­tions spé­ci­fiques au déve­lop­peur et aux péri­phé­riques de test.


2.2.2.  Le projet

Le projet est l'élé­ment central pour la création d'une appli­ca­tion :


                	Il définit les liens et les règles de mise en œuvre des fichiers qui com­posent l'ap­pli­ca­tion.

                	Il sert de cadre à l'édi­teur de code source et aux dif­fé­rentes fonc­tions asso­ciées à l'écri­ture des ins­truc­tions.

                	Il lance les étapes de construc­tion d'une appli­ca­tion telles que la com­pi­la­tion ou la trans­for­ma­tion de certains fichiers.

                	Enfin, il associe le code source et l'en­vi­ron­ne­ment d'exé­cu­tion de l'ap­pli­ca­tion lors du débo­guage de celle-ci.

              

Un projet est maintenu à l'in­té­rieur d'un réper­toire. Les éléments prin­ci­paux de ce réper­toire sont :


                	Le fichier .xcodeproj qui contient toutes les infor­ma­tions du projet. Ce fichier doit être au niveau prin­ci­pal du réper­toire.

                	Les fichiers sources et mul­ti­mé­dia qui peuvent être regrou­pés dans des sous-répertoires à la conve­nance du déve­lop­peur.

                	Le sous-répertoire build qui contient les dif­fé­rentes variantes d'exé­cu­table et les fichiers d'index des symboles définis dans le projet.

              

Pour tra­vailler sur un projet, il faut demander à Xcode d'ouvrir le fichier .xcodeproj cor­res­pon­dant à ce projet. Le projet est alors repré­senté par sa fenêtre prin­ci­pale. La partie gauche de cette fenêtre, inti­tu­lée Groups & Files, permet de sélec­tion­ner les éléments qui com­posent le projet.

Le projet lui-même est sym­bo­lisé par une icône portant son nom au sommet de cette section (repère 1 de la figure 2.2). Cette icône contient la struc­ture du projet.

Les fichiers com­po­sant le projet sont affichés à l'in­té­rieur de cette struc­ture. Les groupes appa­raissent sous la forme de dossiers jaunes (repère 2 de la figure 2.2). Ils repré­sentent de simples indi­ca­tions de clas­se­ment définies par le déve­lop­peur : Xcode ignore la struc­ture des groupes lors des opé­ra­tions de construc­tion.

Les opé­ra­tions de glisser/déposer per­mettent d'or­don­ner et de classer les éléments du projet à l'in­té­rieur de ces groupes. Le menu du bouton Action appliqué aux dif­fé­rentes icônes repré­sen­tant le projet permet de gérer ces groupes.
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    Fig. 2.2  La structure du projet

  



Les fichiers sources et mul­ti­mé­dia appa­raissent dans cette section lors­qu'ils sont « ajoutés » au projet. La fenêtre d'ajout (figure 2.3) est obtenue :


                	lors de la création d'un fichier ;

                	par le menu Project > Add to project... ;

                	par glisser/déposer d'un fichier depuis le Finder.
	[image: Vautherin_chap_2Fig3.eps]


Fig. 2.3  La fenêtre d'ajout de fichier






              

Dans la suite de cet ouvrage, nous uti­li­sons les valeurs par défaut repré­sen­tées par la figure 2.3.

Xcode sait main­te­nir des « ins­tan­ta­nés » (Snap­shots) des éléments contenus dans le projet à un instant donné. Ces « ins­tan­ta­nés » sont très utiles lorsque l'on tente des modi­fi­ca­tions impor­tantes dans le projet. Si ces modi­fi­ca­tions s'avèrent mau­vaises, cette fonction permet de ramener le projet dans un des états pho­to­gra­phiés.

Les « ins­tan­ta­nés » sont gérés par le menu File > Snap­shots (figure 2.4)
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    Fig. 2.4  La gestion des Snapshots

  




2.2.3.  L'éditeur de code

L'édi­teur de code de Xcode offre les fonc­tion­na­li­tés sui­vantes :


                	Le colo­riage syn­taxique qui associe des couleurs aux mots-clés et aux symboles.

                	L'auto-indentation qui gère les retours à la ligne.

                	L'auto-complétion qui termine l'écri­ture des symboles reconnus.

                	Le pliage de code (code folding) qui permet de masquer le détail des blocs de code (repère 5 de la figure 2.5).

                	Les fonc­tions de rechercher/remplacer avec affi­chage de toutes les occur­rences (figure 2.5).

              

Les para­mètres de ces fonc­tion­na­li­tés sont acces­sibles par les sections Text Editing, Fonts & Color et Inden­ta­tion du panneau des pré­fé­rences de Xcode (menu Xcode > Pre­fe­rences).
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    Fig. 2.5  L'éditeur de code

  




2.2.4.  La navigation

La barre de navi­ga­tion située au sommet de l'édi­teur permet un accès rapide :


                	aux derniers fichiers ouverts (repères 1 et 2 de la figure 2.5) ;

                	aux fichiers de défi­ni­tion liés (repère 3 de la figure 2.5) ;

                	aux méthodes ou fonc­tions (repère 4 de la figure 2.5).

              

On peut aussi créer des signets pour les fichiers les plus fré­quents d'un projet. L'option Add to Book­marks est dis­po­nible dans le menu du bouton Action lors­qu'un fichier est sélec­tionné. Les signets sont regrou­pés dans le dossier Bookmark affiché par la section Groups & Files du projet.

La fonction Edit > Find in project... permet des recherches trans­ver­sales sur plu­sieurs fichiers. Parmi les options pos­sibles, la case Display Results in Find Smart Group mémorise cette recherche trans­ver­sale dans le dossier Find Results de la section Groups & Files du projet. Il est ainsi très facile de retrou­ver, à tout instant, l'en­semble des occur­rences d'un élément appa­rais­sant à plu­sieurs endroits dans le projet.

Enfin, des dossiers intel­li­gents per­mettent de regrou­per dyna­mi­que­ment les fichiers grâce à leur nom (filtre simple ou expres­sion régu­lière). Le menu Project > New Smart Group permet de créer un nouveau dossier intel­li­gent. Le panneau d'in­for­ma­tion du dossier définit les critères de recherche.


2.2.5.  La construction


2.2.5.  Les versions de SDK

Le SDK pour iPhone OS est, en fait, consti­tué de plu­sieurs unités nommées SDK. Chaque SDK est un ensemble de biblio­thèques repré­sen­tant une version donnée du système : 3.0, 3.1, 3.1.2, 3.2, etc.

La construc­tion d'un projet s'ar­ti­cule autour de trois versions pos­sibles de SDK :


                  	la version de base ;

                  	la version cible de déploie­ment (Deploy­ment Target) ;

                  	la version active.

                

La version de base déter­mine les biblio­thèques avec les­quelles l'ap­pli­ca­tion est liée. Cette version est fixée par le menu Base SDK de la section General du panneau d'in­for­ma­tion du projet (bouton Info ou menu File > Get Info).

La version cible de déploie­ment repré­sente la version minimale du système à partir de laquelle l'ap­pli­ca­tion peut fonc­tion­ner sur un péri­phé­rique. C'est cette version du système qu'in­dique l'App Store dans les carac­té­ris­tiques d'une appli­ca­tion. Par défaut, la valeur de cette version est égale à celle de Base SDK. Pour la modifier, il faut accéder au réglage iPhone OS Deploy­ment Target de la section Build du panneau d'in­for­ma­tion du projet. L'accès rapide s'ef­fec­tue grâce au champ recherche de ce panneau (voir figure 2.6).
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    Fig. 2.6  La version cible de déploiement

  



La version active déter­mine les biblio­thèques avec les­quelles l'ap­pli­ca­tion peut s'exé­cu­ter. La version active est toujours supé­rieure ou égale à la version de base. Si la version active est supé­rieure à la version cible de déploie­ment (et que cette dernière est supé­rieure ou égale à 3.1), les biblio­thèques iPhone OS les plus récentes sont liées de manière « lâche » (weak linking). Cela signifie que les appels aux fonc­tion­na­li­tés les plus récentes ne sont pas rejetés au moment de la construc­tion du projet mais que l'ap­pli­ca­tion doit vérifier leur dis­po­ni­bi­lité en mettant en œuvre les tests décrits au chapitre 12.

La figure 2.7 illustre le cas général d'uti­li­sa­tion des fonc­tion­na­li­tés d'iPhone OS en fonction des trois versions de SDK définies par le projet :
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    Fig. 2.7  Versions et fonctionnalités disponibles

  



Une appli­ca­tion uni­ver­selle doit s'exé­cu­ter à la fois sur iPhone (iPhone OS 3.1) et sur iPad (iPhone OS 3.2). La solution consiste donc à fixer :


                  	la version cible de déploie­ment à 3.1 ;

                  	la version de base et la version active à 3.2.
	[image: Vautherin_chap_2Fig8.eps]


Fig. 2.8  Application universelle






                


                  Au moment de la rédac­tion de cet ouvrage, la version 10.6 de Mac OS X ne met pas en œuvre le weak linking. Le simu­la­teur fonc­tionne avec Mac OS X. Il remplace donc le weak linking par des liens « forts » avec la version de base. Les tests de com­pa­ti­bi­lité avec la version cible de déploie­ment doivent impé­ra­ti­ve­ment être réalisés sur un péri­phé­rique.

                


2.2.5.  Les configurations de développement

Une confi­gu­ra­tion de déve­lop­pe­ment pour un projet repré­sente un ensemble de réglages pour la construc­tion de ce projet. Par défaut, tout projet possède les confi­gu­ra­tions Debug et Release.

La confi­gu­ra­tion Debug est destinée à produire une appli­ca­tion com­por­tant des ins­truc­tions de débo­guage. La confi­gu­ra­tion Release est destinée à produire l'ap­pli­ca­tion finale.

Les confi­gu­ra­tions sont gérées par la section Confi­gu­ra­tions du panneau d'in­for­ma­tion du projet. Le chapitre 16 décrit comment créer une confi­gu­ra­tion dédiée à la dis­tri­bu­tion de l'ap­pli­ca­tion sur l'App Store.

L'annexe B explique aussi comment générer du code par­ti­cu­lier à chaque confi­gu­ra­tion.


2.2.5.  L'exécutable

L'ap­pli­ca­tion créée est repré­sen­tée dans le dossier Products. En sélec­tion­nant son icône et en choi­sis­sant l'option Reveal in Finder on accède à son bundle (voir chapitre 8).

Selon, les réglages de la construc­tion du projet, cet élément est destiné à être :


                  	soit lancé par le simu­la­teur ;

                  	soit chargé sur un péri­phé­rique iPhone OS ;

                  	soit télé­chargé sur l'App Store.

                

Dans le premier cas, le code généré est, en fait, celui d'une appli­ca­tion Mac OS X Intel. Dans les deux autres cas, le code généré utilise des ins­truc­tions ARM et il doit être signé pour pouvoir être accepté par un péri­phé­rique.

La signa­ture est réalisée grâce au réglage Code Signing Identity du panneau d'in­for­ma­tion du projet. Il est recom­mandé de sélec­tion­ner le profil cor­res­pon­dant dans la section Auto­ma­tic Profile Selector :


                  	
iPhone Deve­lo­per pour charger sur un péri­phé­rique ;

                  	
iPhone Dis­tri­bu­tion pour télé­char­ger sur l'App Store.


                

Si ces options ne sont pas dis­po­nibles, vous devez vérifier les ins­tal­la­tions de profils décrites au chapitre pré­cé­dent.

Xcode manipule l'ap­pli­ca­tion créée au travers d'un élément « exé­cu­table » placé sous la rubrique Exe­cu­tables de la section Groups & Files. Cet exé­cu­table donne accès au bundle et définit des para­mètres de lan­ce­ment grâce à son panneau d'in­for­ma­tion.


2.2.5.  Cible de développement

Une cible de déve­lop­pe­ment (target) décrit la logique de construc­tion de l'ap­pli­ca­tion. Une cible est composée de phases de construc­tion.

Les phases habi­tuelles sont :


                  	Copie des fichiers de res­sources dans le bundle (voir chapitre 8).

                  	Com­pi­la­tion des fichiers sources.

                  	Édition des liens.

                

Les modèles de projet de Xcode créent la cible de construc­tion et ses dif­fé­rentes phases. Tou­te­fois, le menu Project permet d'ajou­ter de nou­velles phases.

La cible définit en par­ti­cu­lier les biblio­thèques avec les­quelles l'ap­pli­ca­tion doit être liée. Ces biblio­thèques sont gérées par la section Général du panneau d'in­for­ma­tion. Pour pouvoir utiliser une classe au sein de l'ap­pli­ca­tion, il faut s'as­su­rer que le fra­me­work auquel elle appar­tient soit défini dans cette liste.

Le bouton « + » au pied de cette liste consti­tue la manière recom­man­dée pour ajouter une nouvelle biblio­thèque.
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    Fig. 2.9  Ajout d'une bibliothèque

  



La cible définit aussi les règles (build rules) appli­quées pour la construc­tion du projet. Une règle est la com­bi­nai­son :


                  	d'un process qui filtre une caté­go­rie de fichiers du projet (par exemple les fichiers sources C) ;

                  	et d'une ins­truc­tion à appli­quer sur ces fichiers. Cette ins­truc­tion peut être un outil tel que le com­pi­la­teur GCC ou bien un script shell.
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Fig. 2.10  La logique de construction






                


2.2.5.  La commande Build

La commande Build est définie par une sélec­tion parmi :


                  	la version active du SDK ;

                  	la confi­gu­ra­tion de déve­lop­pe­ment ;

                  	l'exé­cu­table ;

                  	et la cible du projet.

                

La sélec­tion est résumée par le menu du bouton Overview.
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    Fig. 2.11  La sélection active pour la construction

  



La construc­tion est incré­men­tale : seuls sont recons­truits les éléments qui ont été modifiés depuis la dernière construc­tion. Il arrive parfois que Xcode semble ignorer une modi­fi­ca­tion. Dans ce cas, le menu Build > Clean est utilisé pour forcer une recons­truc­tion totale du projet.


2.2.6.  L'exécution

La construc­tion d'une appli­ca­tion est géné­ra­le­ment suivie de son exé­cu­tion. Si l'exé­cu­table est destiné au simu­la­teur, l'ap­pli­ca­tion est ins­tal­lée à l'in­té­rieur de son espace d'exé­cu­tion puis le simu­la­teur se lance en ouvrant direc­te­ment l'ap­pli­ca­tion.

Si l'exé­cu­table est destiné à un péri­phé­rique, celui-ci doit être connecté à la machine de déve­lop­pe­ment et son écran prin­ci­pal doit être débloqué. L'ap­pli­ca­tion est alors ins­tal­lée dans le péri­phé­rique et elle est lancée.

L'exé­cu­tion peut être suivie par la console, acces­sible par le menu Run > Console. L'annexe B explique comment afficher des messages sur cette console.


2.2.7.  L'organiseur

L'or­ga­ni­seur ras­semble vos infor­ma­tions per­son­nelles telles que :


                	les projets essen­tiels ;

                	les infor­ma­tions sur les péri­phé­riques reconnus par la confi­gu­ra­tion de déve­lop­pe­ment ;
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