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    Sobre o livro

    
        
        
            O Google App Engine é uma plataforma de computação nas nuvens que permite a execução de aplicações Web na infraestrutura do Google. Tudo isso de forma fácil e escalável, sem a necessidade de manutenção em sistemas operacionais ou servidores.

Ele possui várias opções de utilização gratuitas, baseadas em cotas e limites, que permitem o desenvolvimento de pequenas aplicações para testes e estudos sem gastar nenhum centavo! Isso torna a plataforma muito atrativa se você está começando e deseja aprender mais sobre ela.

Este livro aborda vários aspectos dessa plataforma, principalmente aqueles relativos ao desenvolvimento de aplicações em Java para interagir com seus recursos, e também a administração deles através das ferramentas disponibilizadas pelo Google App Engine, ou GAE, como é comumente chamado.

Os principais tópicos deste livro são:


	Conceitos básicos do Google App Engine;

	Como desenvolver e hospedar serviços REST com Jersey no GAE;

	Como trabalhar com o Google Datastore;
	Entidades

	Consultas

	Administração





	Como desenvolver uma aplicação no GAE utilizando o Google Cloud Messaging para enviar mensagens a aplicativos móveis;

	Como agendar tarefas no GAE para invocar um serviço em sua aplicação;

	Como utilizar OAuth, como mecanismo de autenticação de usuários, para proteger o acesso aos serviços da sua aplicação;

	Como gerar, visualizar e gerenciar os logs das aplicações Java hospedadas no GAE;

	Como trabalhar com memory cache para armazenar dados temporários em memória de forma rápida, mas não persistente; 

	Como visualizar e gerenciar os erros gerados pela aplicação.



Ao longo do livro, alguns projetos Java serão criados para o GAE. O código-fonte deles estão no GitHub, no seguinte endereço: https://github.com/siecola/GAEBook.

Para o desenvolvimento desses projetos, você poderá usar a IDE Eclipse, juntamente com algumas ferramentas fornecidas pelo Google. Há um capítulo dedicado à preparação do ambiente de desenvolvimento.

Você também pode participar do grupo de discussão deste livro, deixando comentários, dúvidas ou sugestões. O link é:
http://forum.casadocodigo.com.br.

A quem se destina este livro

Esse livro é útil para desenvolvedores de aplicações Web que desejam conhecer sobre a plataforma de computação nas nuvens Google App Engine. Será possível aprender a trabalhar com suas tecnologias, ferramentas e técnicas para construir sistemas arquitetados para serem escaláveis. 
Para administradores de sistema, este livro traz tópicos essenciais para aqueles que desejam administrar aplicações que serão hospedadas no Google App Engine, pois há uma boa parte do conteúdo dedicado a isso.

É interessante que o leitor possua familiaridade com Java e programação orientada a objetos, bem como com a IDE Eclipse, para poder aproveitar com mais intensidade o material apresentado, e se aventurar nos exercícios propostos. Porém, o livro aborda todos os conteúdos de forma didática, construindo os exemplos desde o início e detalhando os conceitos a partir de um nível que possa ser compreendido por programadores com qualquer nível de experiência.
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    Capítulo 1

O que é Google App Engine

    
        
        
            O Google App Engine é uma plataforma de computação nas nuvens que permite a execução de aplicações Web na infraestrutura do Google, de forma fácil e escalável, sem a necessidade de manutenção em sistemas operacionais e servidores. Todas as aplicações ficam hospedadas sob o domínio appspot.com, e podem ser acessadas por todo o mundo ou apenas por pessoas/aplicações autorizadas.

As aplicações podem ser desenvolvidas em Java, Python, PHP e Go, com um ambiente de runtime específico para cada linguagem.

O estilo de cobrança do Google App Engine é o pay as you go, ou seja, você só paga pelo tanto que a aplicação usar de recursos da plataforma. Porém, é possível iniciar o desenvolvimento sem pagar nada, com limites razoáveis de banda, armazenamento e número de acessos por mês. Esses limites são suficientes para provas de conceitos, estudos e até mesmo aplicações de pequeno porte.

Durante este livro, será utilizada a linguagem de programação Java para o desenvolvimento de aplicações de exemplo, que serão hospedadas no Google App Engine. Por isso, o foco das descrições a partir desse ponto será exclusivo para essa linguagem.

1.1 Sandbox

As aplicações no Google App Engine rodam em um ambiente seguro e controlado, que limita e controla o acesso ao sistema operacional onde está sendo executado. Tais limitações permitem que a infraestrutura controle melhor a alocação de recursos e máquinas para as diversas aplicações. Alguns exemplos dessas limitações são:


	As aplicações só podem ser acessadas por meio de requisições HTTP ou HTTPS em portas padrões;

	Não é possível escrever em arquivos. Para leitura, só é possível ler arquivos que foram carregados pela própria aplicação. Para armazenamento de dados, a aplicação deve usar os mecanismos oferecidos pela plataforma, que serão vistos mais adiante;

	A aplicação só é executada em resposta a alguma requisição HTTP ou através de uma tarefa que foi agendada, devendo responder em até 60 segundos.



1.2 Armazenamento de dados

O App Engine fornece quatro formas de armazenamento de dados:


	
Google Cloud Datastore: fornece um esquema de armazenamento de dados do tipo NoSQL, com mecanismos de buscas e operações atômicas. Ele pode ser utilizado por aplicações que não serão portadas para outro tipo sistema de armazenamento, como banco de dados relacionais (como o MySQL);

	
Google Cloud SQL: provê um serviço de banco de dados relacional, semelhante ao MySQL. Essa é uma opção a ser escolhida caso haja a possibilidade da aplicação ter de ser portada para outra plataforma que possui um sistema de armazenamento com banco de dados relacional. É importante ter essa informação para poder decidir entre esse sistema e o Google Cloud Datastore;

	
Google Cloud Storage: fornece um serviço de armazenamento completamente gerenciável de objetos e arquivos com tamanhos da ordem de terabytes. Ele pode ser usado como repositório de arquivos ou de websites, armazenamento de backups ou logs. Os dados armazenados nesse serviço podem ser gerenciados por uma aplicação, utilizando bibliotecas específicas, pelo console do Google Cloud Platform, ou como sistema de arquivos mapeado em um sistema operacional. 

	
Blobstore: é usado para a aplicação armazenar e fornecer objetos chamados blobs, que são muito maiores do que os tipos de dados que podem ser armazenados no serviço de Datastore. Pode ser utilizado em conjunto com o Google Cloud SQL ou o Datastore, para casos onde, por exemplo, a aplicação deve armazenar uma foto, vídeo ou um arquivo muito grande que não será guardado em um banco de dados.



Neste livro, será mais usado o mecanismo Google Cloud Datastore para armazenamento dos dados das aplicações de exemplo que serão criadas. Isso porque se trata de um serviço gratuito para o volume de dados que será utilizado, além de ser simples e, ao mesmo tempo, eficiente.

Obviamente, uma aplicação pode usar mais de um mecanismo de armazenamento de dados, por exemplo, utilizar o Datastore como banco de dados principal, com dados dos usuários, transações etc., e o Blobstore para fotos. 
A escolha entre os mecanismos de armazenamento deve levar em conta fatores como:


	
Custo de armazenamento: o Datastore possui preços menores e até planos gratuitos, com certos limites, em relação ao Cloud SQL;

	
Tipo do dado a ser armazenado: a escolha entre um banco relacional ou um NoSQL deve ser levada em conta entre usar o Datastore ou o Cloud SQL;

	
Possibilidade de portar a aplicação para outras plataformas: utilizar o Cloud SQL pode tornar a aplicação mais fácil de ser portada para outras plataformas, com pequenas ou, até mesmo, nenhuma modificação;

	
Tamanho do dado a ser armazenado: o armazenamento de fotos e arquivos grandes requer serviços como o Blobstore ou o Cloud Storage.



1.3 Agendamento de tarefas

Tarefas podem ser agendadas para serem executadas, sem a necessidade de responderem a requisições HTTP externas. Essa facilidade permite que a aplicação execute procedimentos agendados (a cada hora ou a cada dia), como requisições a recursos externos ou processos de limpeza do sistema de armazenamento.

1.4 Cotas e limites

Para começar a desenvolver com o Google App Engine, basta criar uma conta e publicar a aplicação. A partir daí, qualquer pessoa poderá acessar de qualquer lugar sem nenhum custo. Porém, existem alguns limites para a utilização gratuita da plataforma, que são:


	Registrar até 10 aplicações por usuário;

	Cada aplicação pode usar até 1 GB de armazenamento de dados (NoSQL) com limite de 50 mil operações de leitura/escrita por dia;

	1 GB de tráfego de entrada e saída por dia.



Existem outros limites que podem ser consultados na página do Google App Engine, porém esses são os mais significativos. Ademais, o Google costuma mudar tais limites, seguindo tendências de mercado, normalmente aumentando algumas das opções gratuitas.

Você também pode habilitar o mecanismo e cobrança da sua aplicação, o que significa que nenhum serviço ou funcionalidade vai parar caso atinja o limite gratuito; mas é claro, será cobrado por isso.

1.5 Console de administração

O Google App Engine possui um console de administração Web, onde várias operações de gerenciamento das aplicações podem ser realizadas. Ele pode ser acessado no endereço https://console.developers.google.com/project.




[image: Página inicial ]Figura 1.1: Página inicial



Essa tela lista os projetos da sua conta no Google Developers Console, com algumas estatísticas. Cada um dos nomes de projeto é um link para seu dashboard de administração, que será detalhado ao longo dos capítulos deste livro.

Você utilizará muito esse console de administração das aplicações que forem publicadas no Google App Engine.

1.6 Conclusão

Agora que você já sabe um pouco sobre o que o Google App Engine, como plataforma, pode oferecer, você poderá preparar seu ambiente de desenvolvimento seguindo as instruções do próximo capítulo.


        
        

    



        
        
    
    


        
        

    Capítulo 2

Preparando o ambiente de desenvolvimento

    
        
        
            Chegou a hora de preparar seu ambiente de desenvolvimento!
Para desenvolver aplicações para o Google App Engine em Java, são necessários os seguintes programas e pacotes:


	
Google App Engine SDK for Java 1.9.30 - Será instalado de dentro do Eclipse.



	
Eclipse IDE for Java EE Developers 4.4 Luna 64 bits - 
https://www.eclipse.org/downloads/packages/eclipse-ide-java-ee-developers/lunasr2.



	
Java Development Kit 7 64 bits -
http://www.oracle.com/technetwork/java/javase/downloads/jdk7-downloads-1880260.html.



	
Google Plugin for Eclipse 4.4 (Luna) -
Será instalado de dentro do Eclipse.





As versões apresentadas dos programas e pacotes formam uma combinação recomendada para o Google App Engine SDK para a versão 1.9.30 e para a linguagem Java. Obviamente, se uma versão mais nova do SDK surgir, talvez possam ser usadas versões mais novas de Eclipse e/ou Java. Tente utilizar essas versões recomendadas, pelo menos durante os exercícios do livro, para que você não tenha contratempos indesejados.

Baixe esses pacotes e siga as instruções nas próximas seções. O plugin do Google para o Eclipse será instalado de dentro do Eclipse.

2.1 Instalando o JDK 7

Dê um duplo clik no arquivo baixado do Java Development Kit 7, e siga as instruções de instalação.

2.2 Google App Engine SDK for Java 1.9.30

O Google App Engine SDK for Java pode ser baixado ou instalado de dentro do Eclipse, que é o que será feito um pouco mais adiante neste capítulo, pois assim tudo já ficará configurado corretamente.

O App Engine SDK possui as seguintes características:


	Todas as APIs e bibliotecas disponíveis da plataforma GAE;

	Um ambiente seguro para simular e testar suas aplicações na sua máquina local de desenvolvimento, que emula a infraestrutura do GAE, sem a necessidade de publicar a aplicação e consumir seus recursos;

	Ferramentas de desenvolvimento para subir a aplicação para o GAE pelo Eclipse.



2.3 Instalando e configurando o Eclipse

Descompacte o Eclipse em uma pasta na sua máquina de desenvolvimento. Depois disso, abra-o clicando em seu executável e execute os passos a seguir:


	
Configure o local do workspace que você desejar:

 


[image: Configurando o local do workspace ]Figura 2.1: Configurando o local do workspace





	
Clique em OK e aguarde até que o Eclipse carregue totalmente;



	
Acesse o menu Window -> Preference para abrir a janela de configurações do Eclipse;



	
Nessa janela, acesse a opção Java -> Installed JREs;



	
Adicione um novo JRE, clicando no botão Add. Selecione o local onde você instalou o JDK 7;



	
Selecione a opção jdk1.7.0_80 como a opção padrão. Isso fará com que as novas aplicações sejam criadas utilizando essa JRE;

 


[image: Configurando a JRE padrão ]Figura 2.2: Configurando a JRE padrão





	
Clique em OK.





2.4 Instalando o Google Plugin for Eclipse

Para instalar o Google Plugin for Eclipse, execute os passos a seguir, dentro do Eclipse:


	
Acesse o menu Help -> Install New Software;



	
Na janela que abrir, clique no botão Add para adicionar o repositório de ferramentas do Google para o Eclipse 4.4;



	
Adicione o endereço https://dl.google.com/eclipse/plugin/4.4 no campo Location no pop-up que se abrir, e clique em OK;

 


[image: Configurando o repositório do Google Plugin for Eclipse ]Figura 2.3: Configurando o repositório do Google Plugin for Eclipse





	
Aguarde até que o Eclipse carregue as opções de ferramentas para a instalação;



	
Depois de o Eclipse carregar as opções de instalação do repositório do Google, selecione as seguintes opções, pelo menos:


	Google App Engine Maven Integration

	Google Plugin for Eclipse 4.4

	
Google App Engine Java SDK 1.9.30

A tela de instalação do Eclipse deverá ficar como a figura a seguir:




[image: Opções de instalação no Eclipse ]Figura 2.4: Opções de instalação no Eclipse









	
Clique em Next;



	
Aceite todos os termos das licenças, e depois cliquem em Finish para dar início ao processo de download e instalação;



	
Depois que tudo for baixado e instalado, o Eclipse pedirá para ser reiniciado;



	
Depois de reiniciar o Eclipse, acesse o menu Window -> Preference e veja que há uma nova opção com o nome de Google;



	
Expanda a opção Google e clique no item App Engine. Veja que o App Engine SDK já está instalado e configurado corretamente:

 


[image: Google App Engine instalado ]Figura 2.5: Google App Engine instalado





	
Nessa mesma tela, vá à opção Java -> Compiler e configure o item Compiler compliance level para 1.7;



	
Repare também que, no canto inferior direito do Eclipse, há a opção para você deixar o Eclipse logado na sua conta do Google. É interessante fazer isso para que ele acesse a sua conta durante a criação de novos projetos, criando uma aplicação nova no GAE;


Utilizando o Maven

O plugin do Google para o Eclipse possui boas ferramentas para a criação e publicação de projetos para o GAE, mas neste livro você criará um projeto utilizando o Maven como gerenciador de dependências. Por isso, o processo será um pouco diferente, mas valerá a pena quando você tiver de acrescentar bibliotecas ao projeto, como será o caso no capítulo Construindo serviços REST com Jersey, onde será inserido o Jersey para trabalhar com REST.





	
Ainda na tela de preferências do Eclipse, vá à opção Maven -> Archetypes e clique no botão Add Remote Catalog para adicionar o catálogo de arquiteturas de projeto, dentre elas a de projetos para o Google App Engine;



	
Na tela que se abrir, preencha o campo Catalog File com o endereço http://repo1.maven.org/maven2/archetype-catalog.xml e clique em OK;



	
Clique em OK para fechar a tela de preferências do Eclipse;



	
Realize as demais configurações no workspace do Eclipse que você desejar ou que já está acostumado.





2.5 Conclusão

Esses foram os passos para a preparação do ambiente de desenvolvimento para trabalhar com o Google App Engine. 
No próximo capítulo, você vai construir sua primeira aplicação em Java e publicá-la no GAE.


        
        

    



        
        
    
    


        
        

    Capítulo 3

Desenvolvendo a primeira aplicação para o GAE

    
        
        
            Para entender como funciona o processo de criação de uma aplicação em Java, e depois como é feita a publicação no GAE, você construirá um primeiro projeto, chamado exemplo1. Nos capítulos seguintes, você vai incrementá-lo, adicionando:


	Um serviço REST;

	Persistência de dados no Google Cloud Datastore;

	Mensagens de log;

	
Autenticação HTTP Basic;

	Interação com o Google Cloud Messaging.



Com isso, você também aprenderá técnicas interessantes de trabalhar com o console de administração do Google App Engine, como:


	Monitorar a execução de uma aplicação;

	Visualizar os acessos, com monitoramento das mensagens de erro;

	Visualizar as mensagens de log geradas pela aplicação;

	Gerenciar o Google Datastore para visualizar e até editar os dados gravados pela aplicação;

	Gerenciar as versões da aplicação;

	Configurar a aplicação para poder utilizar o Google Cloud Messaging.



3.1 Construindo o projeto básico

Para começar a criar o projeto exemplo1, execute os passos a seguir:


	
Vá até o endereço https://console.cloud.google.com/project, e clique no botão Create project, para criar um novo projeto no GAE:

 


[image: Criar novo projeto no GAE ]Figura 3.1: Criar novo projeto no GAE





	
Na tela que aparecer, escolha o nome do seu projeto. Lembre-se de que esse nome será o Project ID, que deverá ser associado na criação do projeto no Eclipse. Ele também deve ser único na plataforma do GAE, pois ele será parte da URL de acesso quando ele for publicado;



	
Se desejar, escolha também a região onde ele será hospedado:

 


[image: Criando novo projeto no GAE ]Figura 3.2: Criando novo projeto no GAE





	
Clique no botão Create e aguarde até que o GAE crie seu projeto;

 Assim que o projeto for criado, você será redirecionado para o dashboard principal da plataforma do Google Cloud. Nos capítulos adiante, você aprenderá algumas ferramentas da seção App Engine desse dashboard.



	
Tendo o Project ID do projeto recém-criado, vá ao Eclipse e acesse o menu File -> New -> Maven Project:



	
Na tela que aparecer, clique em Next;



	
Na opção Catalog, escolha o catálogo adicionado no capítulo anterior e, em seguida, filtre por com.google.appengine.archetypes;



	
Dentre as opções que aparecerem, escolha o Artifact Id com o nome de appengine-skeleton-archetype, como mostra a figura a seguir:

 


[image: Escolha do tipo do projeto ]Figura 3.3: Escolha do tipo do projeto





	
Clique em Next e preencha os dados para a criação do novo projeto:

 


[image: Dados para criação do projeto ]Figura 3.4: Dados para criação do projeto



 Nessa tela, é importante se atentar para a versão do App Engine, que no caso foi colocado 1.9.30 e o Application Id, que deve ser igual ao que você criou para o novo projeto no console do GAE.



	
Clique em Finish para a criação do projeto e aguarde.

 Dois erros de verificação do Eclipse aparecerão nos arquivos nbactions.xml e pom.xml. Não é necessário tomar nenhuma atitude para que o projeto funcione, mas o Eclipse pode ficar reclamando toda vez que você for publicar o projeto. Por isso, se desejar, continue executando os passos a seguir:



	
No arquivo nbactions.xml, remova as três primeiras linhas desse arquivo para resolver o primeiro problema de verificação apontado pelo Eclipse, como dito no passo anterior:

 #set( $symbol_pound = '#' )
 #set( $symbol_dollar = '$' )
 #set( $symbol_escape = '\' )




	
No arquivo pom.xml, vá até onde o Eclipse mostra o erro, que é em uma tag com o nome de execution, posicione o cursor e pressione CTRL + 1 para abrir as opções de correção desse erro;



	
Clique na opção Permanently mark goal..., que aparece duas vezes. Repita o processo novamente. Isso vai resolver o segundo problema de verificação do Eclipse que, como dito nos passos anteriores, apenas indica que ele encontrou algo de errado. Deixar esse erro pode ser um pouco irritante toda vez que você for colocar a aplicação para rodar.



	
Clique no projeto e acesse o menu Maven -> Update Project. Certificar-se de que seu projeto está completamente atualizado com todas as dependências que o arquivo pom.xml do Maven diz para ele ter. Seu projeto agora deve ficar sem nenhum erro.    
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