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Foreword




This EBook refers to version 2.10.* released in 2019. In  this edition, the innovations up to 2023 (version 2.10.34) have been included. Many of the functions described here were in earlier versions are not yet available.

In particular, new functions were added that make working with


	
High colour depths


	
Linear colour spaces


	
Large displays


	
new tools


	
and many levels





facilitate.
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Whenever image processing is mentioned in connection with free - Open Source Software - the name "GIMP" appears in a central position.  There are good reasons for this.

GIMP, the GNU IMage Processing Programm, offers you with quite a bit of security everything you (presumably) expect from image processing and probably a whole lot more. Some special features distinguish GIMP:


	
No secrets, no back doors: With GIMP as free software you can safely be that no company is in any way mischievous with your data. There are no back doors …


	
Variety of functions: Furthermore, GIMP really offers you many and far-reaching functions to enhance your images. Due to the long development history of more than 25 - now about 30 - years and the availability of the source code, many people have already helped to improve and expand GIMP. Today you really have many, often quite simple but strong functions to use. For many of the available functions you have to pay a lot of money for commercial software without that their results are significantly better…


	
Active community: Furthermore, the openness of the source code offers all interested (and ambitious) programmers an immediate opportunity to support the project and add further functions. Since the interfaces are of course also open, it is relatively easy to develop plugins and scripts that provide new features or combine existing ones.


	
Many tips: This is where our EBooks come in. The experience of the last 10 to 15 years and many courses held have shown us that it often only takes a small tip or nudge to eliminate a "big" problem or solve a task.


	
EBooks: In several parts - from basics to examples, recurring tasks and method to special filters and important extensions - we summarise in this EBook a small selection of information that should make the work easier for beginners as well as already more experienced users. Your help is very important to us - please let us know your opinion and suggestions about this book.





Take part: We, the authors and publishers of this book, invite you to support our project. Please send your criticism and suggestions to this address:

gimper@gmx.COM

Happy GIMPing!

The GIMPers

PS: This EBook is the first part of a multi-part book series on the subject of GIMP. The focus of this part is on the basic functions of this software. Further parts of the series will deal with various other tools, filters and extensions as well as special techniques, among other things.

P.PPS: A bonus tip: Use the versions of GIMP provided at http://www.gimp.org for your work, especially on Windows. Experience shows that the versions distributed by other providers are often faulty or not very up-to-date.






Part 1: Basics




To work effectively with GIMP, you need some, relatively little, basic knowledge. The first chapter imparts this knowledge without going into too much detail.

Every user should have everything summarised in this chapter at hand in order to be able to work effectively with GIMP.



Tip 1: Golden rules for working with GIMP.




Before explaining the interface of GIMP, some "golden rules" should be introduced that will certainly make your work with GIMP easier.


	
(Undo) All actions you have carried out with GIMP can be undone *step by step by pressing the key combination [Ctrl][z]. (This does not apply to the selection of tools: here you simply select another tool).


	
(Redo) If you have undone one step too many, [Ctrl][y] redoes this step.


	
(ESC) An initiated action - for example, creating a selection with the lasso - can usually be cancelled with the [ESC] key.


	
If an action has no effect - you erase something and it does not disappear - always check first whether you are working on the correct layer. You can see which one is "active) in the Layer Dock.


	
Is there a Floating Selection? In this case you can only edit this layer. It can be converted into a "normal" layer with the "New layer" button (the first one on the far left under the Layer Dock).


	
Then check whether another visible layer is covering the active layer and you therefore cannot see the result.


	
Layers displayed in another Layer Mode as normal sometimes seem to "disappear" when there is no longer a visible layer under them.


	
Since the introduction of Layer groups it happens that users try to work on the Layer Groups - instead of the layers contained there. GIMP does not support this. Select a layer in the group to edit.


	
GIMP has a special feature if you have manipulated the channels in Channel Dock. Afterwards no layer is activated, so you have to do this explicitly in Layer Dock before the next action.


	
It is equally important to determine if a Selection exists. If it does, you can only make changes within the selection. [Ctrl][Shift][a] removes the selection, this is equivalent to selecting the whole image (with [Ctrl][a]) and allows editing throughout the image.


	
For all the Tools, check whether there may be options set here that produce no or incorrect results.












Part 2: Knowing GIMP’s User Interface




GIMP has two variants of the interface. After starting, you will see either the Classic Interface or the Single Window Mode.


Figure 1. The "Classic" interface of GIMP consists of three separate windows.
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In the Classical Mode there is one window each for the Toolbox, the Editing Window and the Dock. For each loaded image, GIMP opens a separate Image Window, which can be quite useful on large screens, as several images can then be displayed side by side.
All windows can be moved separately in this mode and closed if necessary.

In the Window menu is the function for switching to Single Window Mode ("Single Window Mode").


Figure 2. A change of the GUI is made in the Window menu by "Single Window Mode".

[image: images/singlewindow-menu.png]





Figure 3. GIMP’s "Single Window Mode" combines the open GIMP windows into one common window.

[image: images/singlewindowmode.png]




GIMP get this second mode since version 2.8. Today, this mode is particularly popular with users because it is often perceived as being clearer.

The same three windows that appear separately in Classic Mode are also available in Single Window Mode:


	
the Toolbox: important and often needed functions are found here,


	
the Editing Window: in this window the image editing takes place and


	
the "Dock": displays different information about the current image.






Note

The interface display of GIMP can be widely customised, see the tips Customise the interface, in Part 2 of this series.





Tip 2:  Understanding the Toolbox




GIMP’s Toolbox is relatively complex. It contains a number of tools that the developers think are often needed and should therefore be available directly. In addition, the foreground and background colours are set in the toolbox and the settings for the current tool can normally be made below the toolbox.


Figure 4. GIMP’s toolbox consists of two parts: In the upper section you select tools, and in the lower section you set their properties. On the left, the classic form of the toolbox is shown, on the right, the compact, nowadays default variant.

[image: images/toolbox.png]




You can get "brief information" (Tooltips)  about each of the displayed tools by letting the mouse pointer linger over them (without pressing a mouse button) for a little while.

For each tool activated in the toolbox, there are settings (or "options") that determine exactly how the tool works.


Important

It is important to know that before using a tool, its settings must be made. Changes made later to the settings will not affect the result produced, but will always apply to subsequent uses of the tool.




Note 1: Tool Selection


You can determine to a certain extent which tools should appear in the toolbox (Set the toolbox). Furthermore, additional information, such as the current colour gradient or the current brush tip, can be displayed here.





Note 2: Resizing


The toolbox is separated from the Image Window by an invisible vertical line.


Figure 5. On the invisible separating line between the Image Window and the toolbox, the mouse pointer changes its shape. This changes the width of the toolbox.

[image: images/invisible-line1.png]








Note 3: Grouped Tools


To make the toolbox clearer, GIMP combines several tools of one type. Thus the Painting Tools, the Transformation Tools and the Selection and Moving Tools are united in one or more groups. The individual Tools can then be selected precisely with the (right) menu button. GIMP remembers which Tool in the group was last used and then offers it directly.








Tip 3: Use Tooltips (short information)




"Tooltips" appear when the mouse pointer lingers over an active element of the interface for a short time without you pressing a mouse button.


Figure 6. If the mouse is over an active element, GIMP displays a short help.
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The tooltips in the toolbox consist of three parts:


	
the name of the Tool ("Move Tool")


	
a short description of the function ("Move layers, selections and other objects")


	
and a key shortcut, displayed in capital letters ("M").





With the displayed shortcut you can call up the corresponding tool directly without having to move the mouse or activate the function in a menu. Shortcuts simplify and speed up work with GIMP considerably. They can be adapted according to your own wishes (Key combinations for any function).


Note 1: Tooltips everywhere


Tooltips are also available for many other elements of the interface, such as in the corners of the Image Window, for buttons in the docks, etc.






The Tool Groups




GIMP’s tools can be broadly divided into these groups:


	
Selection_Tools:
  Tools to select parts of the image for editing.


	
Measurement Tools:
  Tools to measure colours, distances, angles.





Translation Tools:
  Tools to move images and parts of images.
(See here for details on these tools).


	
Transformation Tools: Tools to rotate, scale and distort and mirror images or parts of images.


	
Text Tool: Tool to apply text to images (see also the section called “Tip 73: Create Logos” for special text displays).


	
Painting Tools: Tools to do various manipulations manually or to simply draw with GIMP.





Each group of tools has specific settings, which differ again in detail for each tool in the group.









Tip 4: Understanding the Editing Window (main window)




GIMP’s "Editing" or "Image Window" is where the actual Editing of Images takes place.

There are a number of important tips on how to work particularly effectively in this window. The next sections summarise them.


Note 1: Maximising the Program Window


In GIMP courses we often find that many users use GIMP with a small, non-screen-filling (program) window. This results in you having a poorer overview of the image than would be possible…. So: Maximise as a first step the GIMP window (in Single Window Mode) or the Editing Window in Classic Mode.





Note 2: Maximise Editing Window


For some edits, the two windows present next to the Edit Window (the Toolbox and the Dock) get in the way. GIMP therefore has a very simple way of closing or redisplaying these windows: the [Tab] key. However, this only works if the Image Window is also active (clicked).






Zooming and Moving in the Editing Window




When editing images, two contradictory requirements occur again and again:


	
You need to have an overview of the entire image.


	
You want or need to see parts of the image particularly closely - in detail - for editing.





There are several ways to meet these conflicting requirements. Firstly, you can change the size of the display in the Image Window - not the "real" image size - at any time, i.e. the "view zoom". Then the displayed image section can be moved (Move in Edit Window).

On the other hand, you can have a picture displayed in several windows ("views") with different resolutions and switch between these views.

If you have several monitors or a very large, high-resolution monitor at your disposal, you can place these windows so that they are visible at the same time.





Tip 5: Zoom the View




There are several ways to adjust the view size of images when editing:


	
The [+] and [-] keys - both in the main keypad and the numeric keypad - increase and decrease the view size of the current image.


	
Together with the [Ctrl] key, turning the mouse wheel directly adjusts the view size.


	
At the bottom of the editing window, on the left-hand side, there is a field in which GIMP displays the current scaling of the view. Other values can also be entered there.






Figure 7. You can scale the view with the mouse or by entering a value.
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Moving in the Editing Window




Whenever the view of the image is larger than the Editing Window, you need an easy way to quickly reach other positions in the image. GIMP offers you several ways to do this.



Tip 6: Move the Image with the Mouse




The easiest way to move the displayed image section is to press the middle Mouse Button and then move the Mouse. The displayed section of the picture moves.
This also works if you do not have a middle Mouse Button. In this case, hold down the [Space] key and then move the Mouse.





Tip 7: Move the Image with the Navigator




In the lower right corner of the Editing Window you will find the so-called "Navigator".


Figure 8. The navigator shows you an overview and allows you to move the displayed area at the same time.

[image: images/navigator1.jpg]




Clicking on this symbol causes GIMP to show you an overview of the current image in which the currently displayed section is marked. You can move it with the Mouse in the Navigator Window.





Tip 8: Move the Image with Buttons and Scrollbars




At the edges of the Editing Window you will find scroll bars with which you can move the displayed image section. However, this method is often more cumbersome than the other possibilities with the mouse.

The displayed section can also be moved with the keys and the mouse wheel. Without an additional key, the mouse wheel moves the section up or down, and if you hold down the [Shift] key, it moves it to the left and right.







Tip 9: Know the Functions in the Corners of the Editing Window.




The four Corners of the Editing Window have these Functions:


	
Top left [image: images/image-window-corners-ul.png]: Display the (normal) menu as Context Menu.


	
Top right [image: images/image-window-corners-ur.png]: Resize the image to fit the Editing Window when resizing. With two clicks, GIMP will fit the image into the Editing Window if the view is small enough.


	
Bottom left [image: images/image-window-corners-dl.png]: Toggle the Quickmask.


	
Bottom right [image: images/image-window-corners-ur.png]: The Navigator.






Figure 9. The four Corners of the Image Window hide special Functions.

[image: images/four-corners.png]








Tip 10: Using Menus in the Editing Window




An often overlooked, useful function can still be found in the Editing Window. There you can call up the normal menu in a special way at any time with the right mouse button.

You will then get a so-called Context Menu. It corresponds completely to the normal menu of the picture window, but is extended by one essential feature. At the top edge of each of the displayed menus, GIMP shows a "tear-off edge". A mouse click on this line transforms the menu into a separate window that can be placed anywhere on the desktop.


Figure 10. The Context Menu in the Image Window allows individual menus to be displayed as separate windows.

[image: images/contextmenu.png]




With large screens, this is a very simple way to make particularly important menus always directly accessible.


Note: Using Context Menus


Many of GIMP’s windows have Context Menus, such as the Info Windows in the dock. These are designed to make the most important functions easily accessible for the context in question.








Knowing and understanding GIMP’s Menus




GIMP’s menus are organised similarly to other image editing programs:


	
The File menu contains functions to Load and Save images. Furthermore, here you will find the functions for printing, for changing EXIF tags and for creating Logos.


	
In the Edit menu, GIMP assembles general functions for editing images. Here you will find, for example, the undo functions as well as functions for copying and pasting and for the program settings ("preferences").


	
Selection menu contains the functions for manipulating Selections.


	
View menu collects GIMP functions to change the appearance of images without affecting the images themselves. Especially important: With Point by Point, GIMP represents image points (pixels) by multiples of the screen pixels.


	
Image menu: Functions for editing entire images (also with multiple layers).


	
Layer-Menu: Functions for working with Layers.


	
The Tools menu lists the tools sorted in groups.


	
In the Filter menu GIMP collects the multiple filters. The first two items are particularly interesting: Repeat Filter ([Ctrl][f]) and Redisplay Filter ([Ctrl][Shift][f]).


	
Window menu: Here you will find the function to switch the display between classic and Single Window Mode.


	
The Help menu contains the Online_Help and a search function for procedures.









Tip 11: Understanding the Status Bar




The status bar at the bottom of the Editing Window gives information about the current "state" of the current layer in the image. As soon as the mouse is over the image, its position is shown at the left edge in the unit selected for the rulers (default: pixels). If this information appears in light grey, the mouse is outside the image.


Figure 11. The status line gives information about the mouse position (leftmost), the units for the rulers, the current scaling of the view and the active layer or current tool (rightmost).

[image: images/statusline.png]




User can change the informations displayed in the Title and Status Bar, see Figure 13, “The Information displayed in the Title and Status Bar can be adjusted.”.





Tip 12: Interpret the Title bar of the Editing Window.




In the title bar you will find information about the current image: the name (on the left), an (internal) reference number, the colour space currently used, the current calculation accuracy or "colour_depth", the number of layers and the image size in pixels. An Asterisk (*) on the far left marks images with unsaved changes, the term "exported" indicates at least one exported version of this image.


Figure 12. The title bar summarises important information about the current image.

[image: images/titlebar.png]




You can change the information displayed there via the settings dialogue
(Edit | Settings | Image Window | Title and Status).


Figure 13. The Information displayed in the Title and Status Bar can be adjusted.

[image: images/title+status-set.png]
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