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			Preface

			SolidWorks 2021 is a parametric, feature-based solid modeling tool that not only unites the three-dimensional (3D) parametric features with two-dimensional (2D) tools, but also addresses every design-through-manufacturing process.  The continuous enhancements in the software has made it a complete PLM software. The software is capable of performing analysis with an ease. Its compatibility with CAM software is remarkable. Based mainly on the user feedback, this solid modeling tool is remarkably user-friendly and it allows you to be productive from day one.

			The SolidWorks 2021 Black Book is the 8th edition of our series on SolidWorks. With lots of additions and thorough review, we present a book to help professionals as well as learners in creating some of the most complex solid models. The book follows a step by step methodology. In this book, we have tried to give real-world examples with real challenges in designing. We have tried to reduce the gap between university use of SolidWorks and industrial use of SolidWorks. In this edition of book, we have included many new features of SolidWorks like Sketch Ink, Silhouette Entities, 3D Textures, Mesh Modeling, DriveWorksXpress, Markup, SolidWorks Inspection, and so on. New practice questions have been added in this edition. The book covers almost all the information required by a learner to master the SolidWorks. The book starts with sketching and ends at advanced topics like Mold Design, Sheetmetal, Weldment, SolidWorks CAM, Rendering, and MBD. Some of the salient features of this book are :

			In-Depth explanation of concepts

			Every new topic of this book starts with the explanation of the basic concepts. In this way, the user becomes capable of relating the things with real world.

			Topics Covered

			Every chapter starts with a list of topics being covered in that chapter. In this way, the user can easy find the topic of his/her interest easily.

			Instruction through illustration

			The instructions to perform any action are provided by maximum number of illustrations so that the user can perform the actions discussed in the book easily and effectively. There are about 1350 illustrations that make the learning process effective.

			Tutorial point of view

			At the end of concept’s explanation, the tutorial make the understanding of users firm and long lasting. Almost each chapter of the book has tutorials that are real world projects. Moreover most of the tools in this book are discussed in the form of tutorials.

			Project

			Free projects and exercises are provided to students for practicing.

			For Faculty

			If you are a faculty member, then you can ask for video tutorials on any of the topic, exercise, tutorial, or concept.

			New Addition

			If anything is added in this edition but is not available in the previous editions, then it is displayed with symbol [image: ]  in table of content. 

			Formatting Conventions Used in the Text

			All the key terms like name of button, tool, drop-down etc. are kept bold.

			Free Resources

			Link to the resources used in this book are provided to the users via email. To get the resources, mail us at cadcamcaeworks@gmail.com with your contact information. With your contact record with us, you will be provided latest updates and informations regarding various technologies. The format to write us mail for resources is as follows:

			Subject of E-mail as Application for resources of ......................... book.

			Also, given your information like

			Name:

			Course pursuing/Profession:

			Contact Address:

			E-mail ID: 

			Note: We respect your privacy and value it. If you do not want to give your personal informations then you can ask for resources without giving your information.

			About Authors

			The author of this book, Matt Weber, has written more than 15 books on CAD/CAM/CAE  available in market. He has coauthored SolidWorks Simulation, SolidWorks Electrical, SolidWorks Flow Simulation, and SolidWorks CAM Black Books. The author has hands on experience on almost all the CAD/CAM/CAE packages. If you have any query/doubt in any CAD/CAM/CAE package, then you can contact the author by writing at cadcamcaeworks@gmail.com

			The author of this book, Gaurav Verma, has written and assisted in more than 16 titles in CAD/CAM/CAE which are already available in market. He has authored Autodesk Fusion 360 Black Book, AutoCAD Electrical Black Book, Autodesk Revit Black Books, and so on. He has provided consultant services to many industries in US, Greece, Canada, and UK. He has assisted in preparing many Government aided skill development programs. He has been speaker for Autodesk University, Russia 2014. He has assisted in preparing AutoCAD Electrical course for Autodesk Design Academy. He has worked on Sheetmetal, Forging, Machining, and Casting designs in Design and Development departments of various manufacturing firms. 

			For Any query or suggestion

			If you have any query or suggestion, please let us know by mailing us on cadcamcaeworks@gmail.com. Your valuable constructive suggestions will be incorporated in our books and your name will be addressed in special thanks area of our books on your confirmation.

		


		
			Chapter 1 

			Starting with

			SolidWorks

			[image: ]

			The major topics covered in this chapter are:

			


			•Installing SolidWorks 2021.

			•Starting SolidWorks 2021.

			•Starting a new document.                                               

			•Terminology used in SolidWorks.                                          

			•Opening a document.                                                                                                   

			•Closing documents.

			•Basic Settings for SolidWorks

			•Workflow in Industries using the SolidWorks

			                                                                                                                                                                                                                                 

		


			Installing SolidWorks 2021

			You can get SolidWorks software installation files in two ways, downloading from website or getting DVD of software from your reseller.

			•If you are installing SolidWorks using the CD/DVD provided by Dassault Systemes then go to the folder containing setup.exe file and right-click on setup.exe in the folder. A shortcut menu is displayed on the screen; refer to Figure-1.

			[image: ]

			•Select the Run as Administrator option from the menu displayed; refer to Figure-1. 

			•Select the Yes button from the dialog box displayed. The ​SolidWorks 2021 Installation Manager will be displayed. Follow the instructions given in the dialog box. Note that you must have the Serial Number with you to install the application. To get more about installation, double-click on the Read Me documentation file in the Setup folder.

			•If you have downloaded the software from Internet, then you are required to browse in the ​SolidWorks Download folder in the Documents folder of Computer. Open the folder of latest version of software and then run setup.exe. Rest of the procedure is same.

			​Starting SolidWorks 2021

			•To start SolidWorks in Windows 10 from Start menu, click on the Start button in the Taskbar at the bottom left corner, click on the SolidWorks 2021 folder. In this folder, select the SolidWorks 2021 icon; refer to Figure-2.

			[image: ]

			•While installing the software, if you have selected the check box to create a desktop icon then you can double-click on that icon to run the software.

			•If you have not selected the check box to create the desktop icon but want to create the icon on desktop, then drag and drop the SolidWorks 2021 icon from the Start menu on the desktop.  

			After you perform the above steps, the SolidWorks 2021 application window will be displayed; refer to Figure-3.

			[image: ]

			Starting A New Document

			There are various methods to start a new document in SolidWorks. The procedure to start a new document in SolidWorks is given next.

			1.Click on the ​New button in the Menu Bar [image: ].

			Or

			2.Move the cursor on the left arrow near the SolidWorks icon; refer to Figure-4 and then click on the File menu button. The File menu will be displayed, click on the New button; refer to Figure-4.

			Or

			3.Press CTRL and N together from the Keyboard. 

			[image: ]

			•After performing any of the above steps, the ​New SOLIDWORKS Document dialog box will be displayed as shown in Figure-5. 

			[image: ]

			•If you are creating first document after installing SolidWorks then Units and Dimension Standard dialog box will be displayed; refer to Figure-6.

			[image: ]

			•Select the unit system and dimension standards that you want to use while creating documents in SolidWorks. These options will be set as default for later documents. You can change these parameters later using System Options. Click on the OK button from the dialog box.

			There are three buttons available in this dialog box; Part, Assembly, and Drawing.

			The ​Part button is used to create Solid, Surface, Sheetmetal, Mesh and other types of models.

			The ​Assembly button is used to create Assemblies.

			The ​Drawing button is used to create drawings from the part models or assemblies.

			You will learn more about solids, surfaces, assemblies, and drawings later in the book.

			Note that the building blocks of CAD are solid models. In SolidWorks, solid models are created by using the tools available in the Part mode. You can start with the Part mode by selecting the Part button in the New SOLIDWORKS Document dialog box.

			•Double-click on the Part button to start the part modeling environment of SolidWorks. On doing so, the application interface will be displayed as shown in Figure-7.

			[image: ]

			The tools available in the Part, Assembly, and Drawing mode are compiled in the form of ​CommandManagers. To display or hide a CommandManager from Ribbon, right-click on a CommandManager in the Ribbon. A shortcut menu will be displayed. Hover the cursor over Tabs option, the list of CommandManagers will be displayed as shown in Figure-8. Select the CommandManager that you want to add to or remove from the Ribbon. Note that a tick mark is displayed before name of CommandManager in the list if the CommandManager is there in the Ribbon. Various CommandManagers available in SolidWorks will be discussed next.

			[image: ]

			​Part Mode CommandManagers

			A number of CommandManagers can be invoked in the Part mode. These CommandManagers with their functioning are described next.

			​Sketch CommandManager

			The tools available in this CommandManager are used to draw sketches for creating solid/surface models. This CommandManager is also used to add relations and smart dimensions to the sketched entities. The Sketch CommandManager is shown in Figure-9.

			[image: ]

			​Features CommandManager

			This CommandManager provides all modeling tools that are used for feature-based solid modeling. The Features CommandManager is shown in Figure-10.

			[image: ]

			​MBD Dimensions CommandManager

			This CommandManager is used to add dimensions and tolerances to the features of a part. The MBD Dimensions CommandManager is shown in Figure-11.

			[image: ]

			​Sheet Metal CommandManager

			The tools in this CommandManager are used to create the sheet metal parts. The Sheet Metal CommandManager is shown in Figure-12. If this CommandManager is not added in the Ribbon, then right-click on any of the CommandManager tab and select the Sheet Metal option from the menu; refer to Figure-13.

			[image: ]

			[image: ]

			​Mold Tools CommandManager

			The tools in this CommandManager are used to design a mold and split core & cavity steel. The Mold Tools CommandManager is shown in Figure-14.

			[image: ]

			​Evaluate CommandManager

			This CommandManager is used to measure entities, perform analysis and so on. The Evaluate CommandManager is shown in Figure-15.

			[image: ]

			​Surfaces CommandManager

			This CommandManager is used to create complicated surface features. The Surfaces CommandManager is shown in Figure-16.

			[image: ]

			​Direct Editing CommandManager

			This CommandManager consists of tools (Figure-17) that are used for editing a feature.

			​[image: ]

			Data Migration CommandManager

			This CommandManager consist of tools (Figure-18) that are used to work with the models created in other packages or in different environments.

			[image: ]

			Weldments CommandManager

			This CommandManager is used to create welding joints in the model and assembly. The ​Weldments CommandManager is shown in Figure-19.

			[image: ]

			SOLIDWORKS MBD CommandManager

			This CommandManager is used to apply Model Based Dimension which means the dimensions are directly applied to model while skipping the steps of generating drawings. Use of SolidWorks MBD in manufacturing industry requires electronic gadgets at shop floor for production and quality checks. These gadgets should be capable of displaying CAD eDrawings. The CommandManager is shown in Figure-20.

			[image: ]

			Render Tools CommandManager

			The tools in Render Tools CommandManager are used to render the image of current model using appearance parameters specified. The CommandManager is shown in Figure-21.

			[image: ]

			SOLIDWORKS CAM CommandManager

			The tools in SOLIDWORKS CAM CommandManager are used to generate NC programs for CNC machines. The CommandManager is shown in Figure-22.

			[image: ]

			SOLIDWORKS CAM TBM CommandManager

			The tools in SOLIDWORKS CAM TBM CommandManager are used to automatically generate toolpaths and operation settings based on specified tolerances and dimension in the MBD; refer to Figure-23.

			[image: ]

			SOLIDWORKS Inspection CommandManager

			The tools in SOLIDWORKS Inspection CommandManager are used to create inspection drawings and reports for various standards and production part approval process(PPAP); refer to Figure-24. You can also use SolidWorks Inspection for First Article Inspection (FAI) and in process inspection applications.

			[image: ]

			Sketch Ink CommandManager

			The tools in Sketch Ink CommandManager are create sketch free-hand using either stylus or fingertips on touch screen devices; refer to Figure-25.

			[image: ]

			Markup CommandManager

			The tools in Markup CommandManager are used to create free hand markings in the part, assembly, or drawing; refer to Figure-26.

			[image: ]

			​Assembly Mode CommandManagers

			The tools in CommandManagers of the Assembly mode are used to assemble the components. The CommandManagers in the Assembly mode are discussed next. 

			​Assembly CommandManager

			This CommandManager is used to insert a component and apply various types of mates to the assembly. The Assembly CommandManager is shown in Figure-27.

			[image: ]

			​Layout CommandManager

			The tools in this CommandManager (Figure-28) are used to create and edit blocks.

			[image: ]

			​Drawing Mode CommandManagers

			You can invoke a number of CommandManagers in the Drawing mode. The CommandManagers that are extensively used during the designing process in this mode are discussed next.

			​Drawing CommandManager

			This CommandManager is used to generate the drawing views of an existing model or an assembly. The Drawing CommandManager is shown in Figure-29.

			[image: ]

			​Annotation CommandManager

			The Annotation CommandManager is used to generate the model items and to add notes, balloons, geometric tolerance, surface finish symbols, and so on to the drawing views. The Annotation CommandManager is shown in Figure-30.

			[image: ]

			The commands available in these CommandManagers will be discussed one by one later in this book.

			​Opening a Document

			Like creating new documents, there are many ways to open documents. Some of them are discussed next.

			•Click on the Open button in the Menu Bar [image: ] or Move the cursor on the SolidWorks icon and then click on the File > Open button from the menu or press CTRL and O together from the Keyboard. 

			•After performing any of the above step, the Open dialog box will be displayed; refer to Figure-31.

			•Select the file type of your file from the File Type fly-out [image: ]in the bottom right corner of the dialog box.

			•Browse to the folder in which you have saved the file and then double-click on it to open.

			[image: ]

			Most of the time people close the application to close the current file and then restart the application to start working again. In SolidWorks, you can close the current file while the application remains open. The steps to do so are given next.

			Note that there is no separate tool in SolidWorks to import models created in other software. You need to use Open tool to import the non native files.

			​Closing a Document

			To close a document, there are two ways displayed in Figure-32.

			•Open the File menu and then click on the Close option from it or click on the Close button [image: ] at the top-right of the current viewport (Viewport is the area in which the model is displayed.) or press CTRL+W.

			[image: ]

			•If you have done some editing in the document then a dialog box will be displayed prompting you to save the document; refer to Figure-33.

			[image: ]

			•Click on the Save all button to save the changes or click on the Don’t Save button to reject the changes.

			Saving the Documents

			There are three tools available in File menu to save document in SolidWorks; Save, Save As, and Save All. If you are working on a model and click on the Save tool for the first time after starting the new document then the Save tool will work as Save As tool. The Save As tool allows you create a new copy of the document in different formats. The Save All tool is used to save all the modified documents currently open in SolidWorks. The procedure to use the Save As tool is discussed next.

			•Click on the Save As tool from the File menu. The Save As dialog box will be displayed; refer to Figure-34.

			[image: ]

			•Specify desired name for the file in the File name edit box.

			•Click in the Save as type drop-down and select the desired format for file; refer to Figure-35. 

			[image: ]

			•Select the Save as radio button to save the current open file with desired settings. Select the Save as copy and continue radio button to save a new copy of currently open file and do not open the new copy while leaving the original file unchanged. Select the Save as copy and open radio button to save a new copy of currently open file and open the new copy while leaving the original file unchanged. 

			•Click in the Description field and specify desired description for the file.

			•If you are saving an assembly file then Include all reference components check box will be active. Select this check box to add a prefix/suffix to the assembly components names and define other parameters for saving assembly components files. The related options will become active. Select the desired radio button; Add prefix or Add suffix and then specify desired text in the next edit box. Click on the Advanced button. The Save As with References dialog box will be displayed; refer to Figure-36. Select the Nested view or Flat view radio button to check assembly components in nested view or flat view.

			•Select the Include broken references, Include Toolbox parts, and/or Include virtual components check boxes to include respective parts while saving them.

			•Click in the Specify folder for selected items edit box and specify the location where you want to save assembly components. 

			•Select the Save all as copy (opened documents remain unaffected) check box if you want to save new copy of all the assembly files in specified folder location.

			•Double-click in desired field of table in the dialog box to change it.

			•Click on the Save All button from the dialog box  to save assembly files.

			Note that once you have saved SolidWorks assembly or part file then next time clicking on Save tool or pressing CTRL+S will not display the Save As dialog box. It will directly save the files.

			[image: ]

			Printing Document

			The Print tool in File menu is used to print documents on paper or in different formats. The procedure to use this tool is given next.

			•Click on the Print tool from the File menu or press CTRL+P. The Print dialog box will be displayed; refer to Figure-37.

			[image: ]

			•Select the desired printer from the Name drop-down in the Document Printer area of the dialog box. 

			•Click on the Properties button from the dialog box. The respected Properties dialog box will be displayed; refer to Figure-38.

			[image: ]

			•Set the other parameters as desired for printing like number of copies, paper size, orientation, resolution, and so on. Click on the OK button from the dialog box to apply properties.

			Applying Page Setup

			•Click on the Page Setup button from the Print dialog box. The Page Setup dialog box will be displayed; refer to Figure-39.

			[image: ]

			•Select the Use system settings radio button or the Use this document settings radio button to use respective page settings for printing.

			•Set the other parameters as desired like print page source, paper size, scale, resolution, drawing color, and so on.

			•Click on the OK button from the dialog box. The Print dialog box will be displayed again.

			Setting Header/Footer for Print Pages

			•Click on the Header/Footer button from the Document Options area of the dialog box. The Header/Footer dialog box will be displayed; refer to Figure-40.

			[image: ]

			•Select the desired options from the Header and Footer drop-downs. If you want to create a custom header/footer then click on the Custom Header button. The Custom Header dialog box will be displayed; refer to Figure-41.

			•Click in the desired section and specify the custom text to be displayed in header or footer. You can also use the buttons like Page Numbers, Date, and so on to specify custom data. After setting desired parameters, click on the OK button. The Print dialog box will be displayed again.

			[image: ]

			Print Margins

			•Click on the Margins button from the System Options area of the dialog box. The Margins dialog box will be displayed; refer to Figure-42.

			[image: ]

			•Clear the Use printer’s margins check box if you want to specify custom margins to keep object within paper boundary and specify desired parameters in the Paper margins area.

			•Click on the OK button from the dialog box to apply parameters.

			Print Range and other Parameters

			•Select the desired radio button from the Print range area and define respective parameters. If your document has multiple sheets for printing generally in case of printing drawings then Current sheet and Sheets radio button will be displayed.

			•Specify the desired number for prints to be produced in the Number of copies edit box.

			•Select the Print background check box from the dialog box if you want to print the background also.

			•Select the Print to file check box if you want to save a printer file.

			•Similarly, set the other parameters and click on the OK button from the Print dialog box. 

			Publishing to eDrawings

			The Publish to eDrawings tool is used to publish model in eDrawings Viewer. eDrawings is a software developed by Dassault Systemes Corporation for sharing models with management. The procedure to publish model is given next.

			•Click on the Publish to eDrawings tool from the File menu. The Save Configurations to eDrawings file dialog box will be displayed; refer to Figure-43.

			[image: ]

			•Select the check boxes for configurations to be included in the eDrawing file.

			•Click on the Options button from the dialog box. The System Options dialog box will be displayed; refer to Figure-44.

			[image: ]

			•Select the Okay to measure this eDrawings file check box if you want to allow measurement of geometry in eDrawing.

			•Select the Allow export to STL for parts & assemblies check box to allow saving of eDrawing as STL from the eDrawing Viewer software.

			•Similarly, set the other parameters as desired in the dialog box and click on the OK button.

			Specifying Password

			•If you want to set password for opening eDrawing file then click on the Password button from the Save Configurations to eDrawings file dialog box. The Password dialog box will be displayed; refer to Figure-45.

			[image: ]

			•Select the Password Required to Open Document check box. The edit box to define password will be activated.

			•Specify the desired password and input the same in Confirm Password edit box. Click on the OK button from the dialog box.

			After specifying desired parameters, click on the OK button from the dialog box. The model will open in eDrawing Viewer; refer to Figure-46. The options of eDrawings Viewer are out of scope of this book. 

			[image: ]

			Packing files for Sharing

			The Pack and Go tool in File menu is used to package the files for sharing with colleagues or client. The procedure to use this tool is given next.

			•Click on the Pack and Go tool from the File menu. The Pack and Go dialog box will be displayed; refer to Figure-47.

			[image: ]

			•Select check boxes for documents to be included in the package.

			•Select the Save to folder radio button if you want to create a new folder for documents or select the Save to Zip file radio button. Specify the desired location for file or folder in adjacent edit box.

			•Select the Add prefix and Add suffix check boxes if you want to add prefixes and suffixes. After selecting the check boxes, specify desired text in adjacent edit boxes.

			•Select the Email after packaging check box if you want to email your client after packaging files.

			•Click on the Save button to save the file.  

			Reloading Files

			The Reload tool in File menu is used to reload the files that have been modified outside the SolidWorks software or the files that have not been updated automatically. The procedure to use this tool is given next.

			•Click on the Reload tool from the File menu. The Reload dialog box will be displayed; refer to Figure-48.
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			•Select the Show full paths check box to check full path of file to be reloaded.

			•Click on the OK button from the dialog box. An information box will be displayed; refer to Figure-49.

			[image: ]

			•Click on the OK button from the dialog box.

			Replacing Component in Assembly

			The Replace tool in File menu is used to replace selected component in the assembly. The procedure to use this tool is given next.

			•Click on the Replace tool from the File menu. The Replace PropertyManager will be displayed; refer to Figure-50.

			•Select the component to be replaced from FeatureManager Design Tree.

			•If there are multiple instances of the same component and you want to replace all the instances then select the All instances check box.

			•Click on the Browse button from the With this one area of PropertyManager. The Open dialog box will be displayed.

			•Select the desired component by which original component will be replaced and click on the Open button. 

			•Select the desired radio button from the Options rollout. If you want to select  configuration of new component with name matching to original one then select the Match name radio button. Select the Manually select radio button if you want to manually select configuration of component.

			[image: ]

			•Select the Re-attach mates check box if you want to reapply the mates. If you have selected this check box then you will be asked to select references for different mates.

			•After setting desired parameters, click on the OK button from the PropertyManager. The Mated Entities PropertyManager will be displayed; refer to Figure-51.

			[image: ]

			•Set the references as desired and click on the OK button from PropertyManager. The mates will be applied. You will learn more about mates later in the book.

			You can use the Find References tool from the File menu in the same way.

			Checking Summary of Document

			The Properties tool in File menu is used to check and manage summary information of file. The procedure to use this tool is given next.

			•Click on the Properties tool from the File menu. The Summary Information dialog box will be displayed; refer to Figure-52.
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			•Specify the parameters like name of design author, title of design, comments and so on for the model.

			•Click on the Custom tab to define custom summary data.

			•Click on the Configuration Specific tab from the dialog box to define various bill of materials related parameters like material name, cost of material, and so on.

			•Click on the OK button after setting desired parameters. 

			Customizing Menus

			You can customize the menu by selecting the Customize Menu option from the File menu. The options to customize menu will be displayed; refer to Figure-53. Clear the check boxes for options to be removed from the menu. After setting desired options for menu, click in the empty drawing area. The menu will be updated accordingly.

			To exit the software, click on the Exit tool from the File menu.

			Till this point, you have learned the basic file handling operations and you have some idea about the interface of SolidWorks. Now, we will discuss about some basic settings that are required for easy working with SolidWorks.

			[image: ]

			​Basic Settings of SolidWorks

			All the settings of SolidWorks are compiled in the Options dialog box. The steps to change the settings for SolidWorks are given next.

			•Click on the Options option in the Tools menu or click on the Options button [image: ] from the Menu Bar. 

			•On performing the above step, the ​System Options dialog box will be displayed as shown in Figure-54. Note that if you have a document opened then the ​Document Properties tab is also added with the ​System Options tab. To get the detail about each and every option, you need to refer to SolidWorks Help Documentation. In this section, we will discuss about some of the important options that are generally required.

			•Click on the ​Sketch option in the left of the dialog box, select the Enable on screen numeric input on entity creation check box from the right to enter dimensions while creating the sketch. Also, select the Create dimension only when value is entered check box to create dimensions only when you have manually entered the dimension value. 

			•If you want to use only fully defined sketches for creating features in SolidWorks then select the Use Fully defined sketches check box. Fully defined sketches are those sketch which have all their entities dimensioned or constrained.

			•Select the Auto-rotate view normal to sketch plane on sketch creation and sketch edit check box to automatically make the sketching plane parallel to screen. 

			•Click on ​Relations/Snaps in the left of the dialog box and then select the Enable snapping check box to enable auto snapping to the key points.

			[image: ]

			•Click on the Document Properties tab if you have any document opened in the viewport. Click on the Units option from the left. The Options dialog box will be displayed as shown in Figure-55.

			[image: ]

			•Select the desired radio button from the right to set the unit system for the current document.

			•Click on the Drafting Standard option from the left area of the dialog box and select the desired dimensioning standard from the Overall drafting standard drop-down; refer to Figure-56.

			[image: ]

			•Similarly, you can set the other options in the dialog box. Note that we will be revisiting this dialog box many times in this book.

			•Click on the OK button from the bottom of the dialog box to save the settings.

			You can also change the units of document by selecting the desired option from the list displayed on clicking on the Unit system flyout at the bottom of the viewport; refer to Figure-57.

			[image: ]

			The other options of the Options dialog box are discussed in appendix pages.

			Mouse Button Function

			Rotate View (parts and assemblies only)

			•To rotate the model view: Drag with the middle mouse button.

			•To rotate about a vertex, edge, or face: Middle-click a vertex, edge, or face; then middle-drag the pointer.

			Pan	

			Hold down CTRL key and drag with the middle mouse button. (In an active drawing, you do not need to hold down CTRL key.)

			Zoom In/Out	

			Hold down Shift and drag the middle mouse button up/down or scroll the mouse wheel downward/upward to zoom in/out.

			Loading Add-Ins

			Add-Ins are used to allow external functions in SolidWorks. Like, you can use SolidWorks Electrical, SolidWorks Simulation, SolidWorks PCB, MasterCAM etc. The procedure to load Add-Ins is given next.

			•Click on the Add-Ins option from the Options drop-down in the Menu Bar; refer to Figure-58. The Add-Ins dialog box will be displayed; refer to Figure-59.

			[image: ]
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			•Select the left side check box for Add-In that you want to be loaded now. If you want to load an Add-In at startup of SolidWorks then select the right-side check box for it.

			•Click on the OK button from dialog box to apply the settings.

			Search Tools

			The Search box at the top-right corner of the application window is a multipurpose tool. You can use this search box to search for help content, commands, cad models, training files etc. The method to use Search box for searching commands is given next. You can apply the same method to search other things.

			•Hover the cursor on SOLIDWORKS logo at the top-left corner of application window and click on the Commands option from the Search cascading menu of Help menu; refer to Figure-60.

			[image: ]

			•Click in the Search box and type few characters of command that you are searching. A list of tools with typed characters will be displayed; refer to Figure-61.

			[image: ]

			•Click on the eye icon displayed next to tool in the list. The cursor will move to the tool location and an arrow will be displayed pointing to the tool; refer to Figure-62. If you click on the tool in the list then it will be activated directly.

			[image: ]

			Note that you can pin the menu bar to display all the menus by clicking on the Pin button; refer to Figure-63.

			[image: ]

			Login to SolidWorks

			The Login to SOLIDWORKS button in the Search Bar is used to login to your SolidWorks account using the software; refer to Figure-64. Using this tool to login allows you to automatically log you into SOLIDWORKS websites, such as: MySolidWorks, SOLIDWORKS Forum,  Customer Portal, and Get Support.

			[image: ]

			​Workflow in SolidWorks

			The first step in SolidWorks is to create a sketch. After creating sketch of the desired feature, we create solid or surface model from that sketch. After doing the desired operations on the solid/surface model, we go for assembly or analyses. After, we are satisfied with the assembly/ analyses, we create the engineering drawings from the model to allow manufacturing of the model into a real world object.

			[image: ]

			Self-Assessment

			Q1. If you have downloaded the SolidWorks Setup files from Internet then the files will be available in Downloads folder of Windows by default. (T/F)

			Q2. We cannot create the desktop icon of SolidWorks if we have not opted for it while installing. (T/F)

			Q3. Status Bar in SolidWorks window also displays the tips related to current tool. (T/F)

			Q4. Which of the following operation results in display of New SolidWorks Document dialog box?

			(a)	Press CTRL+N

			(b)	Click on New button from Menu Bar 

			(c)	Click on New Document link button from Task Pane.

			(d)	All of the above

			Q5. Which of the following is not an option in the New SolidWorks Document dialog box?

			(a)	Part

			(b)	Assembly

			(c)	Drawing

			(d)	Sketch

			Q6.	The ............... CommandManager provides all modeling tools that are used for feature-based solid modeling.

			Q7.	The .............. CommandManager is used to add dimensions and tolerances to the features of a part.

			Q8.	The .......... CommandManager is used to insert a component and apply various types of mates to the assembly.

			Q9.	Write down the steps to close the current document in SolidWorks.

			Q10.	How can we change the unit system of current SolidWorks document?

			Q11. What is the purpose of Add-Ins in SolidWorks?

			Q12. The .................... check box forces SolidWorks to use only fully defined sketches for creating features.

			Answer to Self-Assessment:

			1. T, 2. F, 3. T, 4. d, 5. d, 6. Features, 7. MBD, 8. Assembly, 12. Use fully defined sketches

		


		
			Chapter 2 

			Sketching

			Basic to Advanced
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			The major topics covered in this chapter are:

			•Basics for Sketching

			•Entity Creation tools

			•Entity Editing tools

			•Dimensioning and Constraining

			•3D Sketching

			•Printing and exporting sketch

		





			Basics for Sketching

			In Engineering, sketching do not mean sketches of birds or animals. It means sketches that are based on real dimensions of real-world objects. In this chapter, we will work with geometric entities like; line, circle, arc, ellipse, and so on which you have used in your school and engineering classes. But this time, we will be using the software in place of traditional geometric tools. Note that sketch is the base for most of 3D Models so you should be proficient in sketching.

			To start with sketching, we must have a good understanding of planes in SolidWorks. Figure-1 shows the names of planes and their respective faces in Isometric View.   

			[image: ]

			In SolidWorks, the planes are displayed in the same orientation as shown in the above figure. To check the planes of SolidWorks, click on the planes (​Front Plane, ​Top Plane, ​Right Plane) in the FeatureManager Design Tree; refer to Figure-2.

			[image: ]

			•To show these planes, select them one by one while holding the CTRL key and right-click. A shortcut menu will be displayed; refer to Figure-3.

			[image: ]

			•Select the ​Show/Hide button [image: ] from the shortcut menu; the planes will be displayed. To hide planes, click on the Show/Hide button again.

			Sketching Plane

			In a CAD software, everything is referenced to other entity like a line created must be referenced to any other geometry so that you can clearly define the position of line in infinite space. But, what if there is no geometry in the sketch to reference from. In these cases, we have tools to create reference geometries like reference planes, axes, points, curves etc. Out of these reference geometries, the sketching plane acts as foundation for other geometries. By default, there are three plane perpendicular to each other in SolidWorks; refer to Figure-4.

			[image: ]

			Relation between sketch, plane, and 3D model

			Sketch has a direct relationship with planes and the outcome which is generally a 3D model; refer to Figure-5. In this figure, rectangle is created on the XY Plane which is also called Front plane. A circle is created on the YZ Plane which is also called Right plane. A polygon is created on the XZ plane which is also called Top plane. In a 3D model, the geometry seen from the Front view should be drawn on the Front plane. Similarly, geometry seen from the Right view should be drawn at Right plane and geometry seen from the Top view should be drawn at the Top plane. 
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