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			Preface

			Creo Parametric 4.0 is a parametric, feature-based solid modeling tool that not only unites the three-dimensional (3D) parametric features with two-dimensional (2D) tools, but also addresses every design-through-manufacturing process.  The continuous enhancements in the software has made it a complete PLM software. The software is capable of performing analysis with an ease. Its compatibility with CAM software is remarkable. Based mainly on the user feedback, this solid modeling tool is remarkably user-friendly as compared to its previous versions and it allows you to be productive from day one.

			 

			To support education, PTC gives free educational version of the Creo to students with a license of 1 year. You can get your free version of software by visiting the following link: 

			 

			http://www.ptc.com/communities/academic-program/products/free-software

			 

			The Creo Parametric 4.0 Black Book is the second edition of our series on Creo Parametric. With lots of additions and thorough review, we present a book to help professionals as well as learners in creating some of the most complex solid models. The book follows a step by step methodology. In this book, we have tried to give real-world examples with real challenges in designing. We have tried to reduce the gap between university use of Creo Parametric and industrial use of Creo Parametric. In this edition of book, we have included many new features of Creo Parametric like 3D printing, MBD (Model Based Definition), Family tables, Mechanism Design, 3D PDFs, and so on. There are about 60 topics newly added in this book which were not in the previous edition. The book covers almost all the information required by a learner to master Creo Parametric. The book starts with sketching and ends at advanced topics like Sheetmetal, Surface Design, 3D Printing and MBD. Some of the salient features of this book are :

			 

			 

			In-Depth explanation of concepts

			Every new topic of this book starts with the explanation of the basic concepts. In this way, the user becomes capable of relating the things with real world.

			 

			 

			Topics Covered

			Every chapter starts with a list of topics being covered in that chapter. In this way, the user can easy find the topic of his/her interest easily.

			 

			Instruction through illustration

			The instructions to perform any action are provided by maximum number of illustrations so that the user can perform the actions discussed in the book easily and effectively. There are about 1200 small and large illustrations that make the learning process effective.

			 

			 

			Tutorial point of view

			At the end of concept’s explanation, the tutorial make the understanding of users firm and long lasting. Almost each chapter of the book has tutorials that are real world projects. Moreover most of the tools in this book are discussed in the form of tutorials.

			 

			 

			Project

			Free projects and exercises are provided to students for practicing.

			 

			 

			For Faculty

			If you are a faculty member, then you can ask for video tutorials on any of the topic, exercise, tutorial, or concept.

			 

			 


			Formatting Conventions Used in the Text

			All the key terms like name of button, tool, drop-down etc. are kept bold.

			 

			 

			Free Resources

			Link to the resources used in this book are provided to the users via email. To get the resources, mail us at cadcamcaeworks@gmail.com with your contact information. With your contact record with us, you will be provided latest updates and informations regarding various technologies. The format to write us mail for resources is as follows:

			 

			Subject of E-mail as Application for resources of ________book.

			Also, given your information like

			Name:

			Course pursuing/Profession:

			Contact Address:

			E-mail ID: 

			 

			Note: We respect your privacy and value it. If you do not want to give your personal informations then you can ask for resources without giving your information.

			 

			 

			 

			 

			 

			 

			About Authors

			The author of this book, Matt Weber, has written many books on CAD/CAM/CAE  available already in market. SolidWorks Simulation Black Books are one of the most selling books in SolidWorks Simulation field. The author has hands on experience on almost all the CAD/CAM/CAE packages. Besides that he is a good person in his real life, helping nature for everyone. If you have any query/doubt in any CAD/CAM/CAE package, then you can contact the author by writing at cadcamcaeworks@gmail.com

			 

			 

			The author of this book, Gaurav Verma, has written and assisted in more than 10 titles in CAD/CAM/CAE which are already available in market. He has authored AutoCAD Electrical Black Books which are available in both English and Russian language. He has also written Creo Manufacturing 2.0 for Engineers and Machinists which covers Expert Machinist module of Creo Parametric. He has provided consultant services to many industries in US, Greece, Canada, and UK. 

			 

			 

			 

			 

			For Any query or suggestion

			If you have any query or suggestion, please let us know by mailing us on cadcamcaeworks@gmail.com. Your valuable constructive suggestions will be incorporated in our books and your name will be addressed in special thanks area of our books on your confirmation.
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			Starting with

			Creo Parametric 

			 

			 


				
					Topics Covered

				

			

			 

			 

			 

			 

			The major topics covered in this chapter are:

			 

			•	Installing Creo Parametric 4.0.

			•	Starting Creo Parametric.

			•	Starting a new document.

			•	Terminology used in Creo Parametric.

			•	Opening a document.

			•	Closing documents.

			•	Basic Settings for Creo Parametric

			•	Model Properties in Creo Parametric

			•	Keyboard shortcuts and Mouse Functions

			 

			[image: ALT_key_tips.png] 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			Installing Creo Parametric 4.0

			•	If you are installing using the CD/DVD provided by PTC then go to the folder containing setup.exe file and then right click on setup.exe in the folder. A shortcut menu is displayed on the screen; refer to Figure-1.

			
				
					[image: Shortcut_menu_for_installation.png]
				

				
					Figure-1. ​Shortcut menu for installation

				

			

			 

			•	Click on the Run as administrator option from the shortcut menu. The User Account Control dialog box will be displayed.

			•	Click on the Yes button from the dialog box. The PTC Installation Assistant dialog box will be displayed; refer to Figure-2.

			•	Click on the Next button from the dialog box. The License Agreement page will be displayed. Accept the agreement and select the check box below the agreement.

			•	Click on the Next button from the dialog box. The license page will be displayed; refer to Figure-3.

			
				
					[image: PTC_Installation_Assistant_dialog_box.png]
				

				
					Figure-2. ​PTC Installation Assistant dialog box

				

			

			 

			
				
					[image: License_page_of_PTC_Installation.png]
				

				
					Figure-3. ​License page of PTC Installation

				

			

			 

			•	Enter the license file location in the edit box under Source column in the License Summary node; refer to Figure-4.

			
				
					[image: License_file_location.png]
				

				
					Figure-4. ​License file location

				

			

			 

			•	Click on the Next button from the dialog box. Select the check boxes for the applications that you are licensed to install and click on the Install button. The software will be installed.

			•	After the installation is finished, click on the Finish button to exit.

			 

			Starting Creo Parametric

			•	Click on the Start button from the Taskbar to open the Start Menu. 

			•	Click on the All Programs option and then click on the PTC Creo folder. Next, click on the PTC Creo Parametric 4.0 option from the menu in Windows 7. The program will start; refer to Figure-5.

			
				
					[image: Start_menu.png]
				

				
					Figure-5. ​Start menu

				

			

			 

			•	On starting the application, the initial screen of the application is displayed as shown in Figure-6.

			
				
					[image: Initial_screen_of_Creo_Parametric.png]
				

				
					Figure-6. ​Initial screen of Creo Parametric

				

			

			 

			•	The elements of interface of the Creo Parametric 4.0 are shown in Figure-7.

			
				
					[image: Creo_Parametric_interface.png]
				

				
					Figure-7. ​Creo Parametric interface

				

			

			 

			The elements in the interface are discussed next.

			 

			Creo Parametric 4.0 Interface

			The interface of Creo Parametric comprises of various elements like Navigator panel, Browser, Ribbon, File menu and so on. These elements are discussed next.

			 

			Navigator panel

			The Navigator panel is used to navigate through folders and features. This panel has three tabs named: Model Tree, Folder Browser, and Favorites. The Model Tree tab will be active only when you have opened a model/assembly file; refer to Figure-8.

			
				
					[image: Model_Tree.png]
				

				
					Figure-8. ​Model Tree

				

			

			 

			•	The Model Tree contains all the features that are created automatically or manually while creating model or assembly.

			•	The Insert Here mark in the Model Tree represents the position where the next feature will be inserted.

			•	Click on the Settings button [image: Settings_button.png] to display the menu related to settings; refer to Figure-9. 

			
				
					[image: Model_Tree_settings.png]
				

				
					Figure-9. ​Model Tree settings

				

			

			 

			•	Using the Open Settings File option, you can open an earlier save setting file. 

			•	To save the existing settings in a file, click on the Save Settings File option. The settings will be saved in .cfg file.

			•	Click on the Tree Filters option to add or remove the entities being displayed. The Model Tree Items dialog box will be displayed; refer to Figure-10.  

			
				
					[image: Model_Tree_Items_dialog_box.png]
				

				
					Figure-10. ​Model Tree Items dialog box

				

			

			 

			•	Select the check boxes that you want to display in the Model Tree and click on the OK button from the dialog box.

			 

			•	Click on the Folder Browser button to display the Folder Browser; refer to Figure-11.

			
				
					Figure-11. ​Folder Browser

				

				
					[image: Folder_Browser.png]
				

			

			 

			•	Using the Folder Browser, you can easily browse through the folders to get the desired files.

			 

			•	The Favorites tab is used to display the locations saved as favorite.  

			•	To display or hide the Navigation panel, click on the Show Navigator toggle button in the Status bar; refer to Figure-12.

			
				
					[image: Show_Navigator_button.png]
				

				
					Figure-12. ​Show Navigator button

				

			

			 

			Ribbon

			Ribbon is the area of the application window that holds all the tools for designing and editing; refer to Figure-13.

			
				
					[image: Ribbon.png]
				

				
					Figure-13. ​Ribbon

				

			

			 

			The tools in the Ribbon will be discussed later in the book as per their need in designing.

			 

			File Menu

			The options in the File menu are used to perform operations related to files; refer to Figure-14.

			
				
					[image: File_Menu.png]
				

				
					Figure-14. ​File Menu

				

			

			 

			The options in the File menu are discussed next.

			 

			New Tool

			The New tool is also available in the Ribbon and Quick Access Toolbar; refer to Figure-15. This tool is used to create a new file. The procedure to use this tool is given next.

			
				
					[image: New_Tool.png]
				

				
					Figure-15. ​New Tool

				

			

			 

			•	Click on the New tool from the desired location. The New dialog box will be displayed; refer to Figure-16.

			
				
					[image: New_dialog_box.png]
				

				
					Figure-16. ​New dialog box

				

			

			 

			•	Select the desired radio button from the Type area of the dialog box. The related sub-types will be displayed in the Sub-type area. 

			•	Select the desired sub-type and specify the name in the Name edit box.

			•	For most of the file types, the Use default template check box is displayed. If this check box is selected then the default template is used for creating new files. The units for default templates are in IPS.

			•	Clear this check box if you want to select any other template. 

			•	Click on the OK button from the dialog box. The file will be created and environment related to selected type will be displayed.

			•	If you have cleared the Use default template check box then the New File Options dialog box will be displayed; refer to Figure-17.

			
				
					[image: New_File_Options_dialog_box.png]
				

				
					Figure-17. ​New File Options dialog box

				

			

			 

			•	Select the desired template and click on the OK button to create the file.

			 

			The description of various file types displayed in the New dialog box is given next.

			 

			Layout

			The Layout radio button in the New dialog box is used to create new layout files. Layout files are used to create layouts based on the ideas. In the layout environment, we can create 2D sketches, we can import images, we can import and edit other layouts, and so on. 

			 

			Sketch

			The Sketch radio button is used to create sketches which are the base blocks for 3D models. 

			 

			Part

			The Part radio button is used to create 3D models. There are four sub-types for this radio button; Solid, Sheetmetal, Bulk, and Harness. 

			 

			•	The Solid sub-type is used to create solid/surface 3D models.

			•	The Sheetmetal sub-type is used to create sheetmetal models. 

			•	The Bulk sub-type is used to create representation of model elements in assembly. For example, you need a generator of specific kind in your assembly but you do not want to model it, then you can save generator in the bill of material (BOM) by making it a bulk part.

			•	The Harness sub-type is used to creating wiring in the model. This button is generally active when you are working in an assembly and from within the assembly, you need wire harness or pipe harness.

			 

			Assembly

			The Assembly radio button is used to create assemblies of solid/sheetmetal parts. There are 10 sub-types for this radio button; Design, Interchange, Verify, Process Plan, NC Model, Mold layout, External simplified representation, Configurable Module, Configurable product, and ECAD.

			 

			•	The Design sub-type is used to create assembly designs.

			•	The Interchange sub-type is used to create a special type of assembly that you can create and then use in a design assembly. An interchange assembly consists of models that are related either by function or representation. You can create both functional interchanges (to replace functionally equivalent components) and simplify interchanges (to substitute components in a simplified representation) in the same interchange assembly. Interchange assemblies, like family tables and layouts, provide a powerful method of automatic replacement.

			•	The Verify sub-type is used to verify the model with respect to the point cloud generated by laser scanner. We get a scan data from the laser scanner for the manufactured assembly and then we compare it with our model.

			•	The Process Plan sub-type is used to document the process of assembling/dis-assembling parts in the assembly.

			•	The NC Model sub-type is used to create manufacturing model of the assembly.

			•	The Mold layout sub-type is used to create layouts for molds.

			•	The External simplified representation sub-type is used to create representations of the assembly. These representations can be saved independent of the parent assembly file.

			•	The Configurable module sub-type is used to create modules that consist of parts and assemblies interrelated to each other by some related. The module can be configured with the help of variables.

			•	The Configurable product sub-type is used to create configurable assemblies. 

			•	The ECAD sub-type is used to create electronic board design.

			 

			Manufacturing

			The Manufacturing radio button is used to create manufacturing models for creating nc codes of cnc machines. There are 8 sub-types available for this radio button; NC assembly, Expert Machinist, CMM, Sheetmetal, Cast cavity, Mold cavity, Harness, Process plan, and Additive Manufacturing. 

			 

			•	The NC assembly sub-type is used to create assembly model for manufacturing a component on nc machine like turning centers and milling centers.

			•	The Expert Machinist sub-type is used to perform the same work as done in NC assembly sub-type. But, the Expert Machinist is a lite version of NC assembly and is having limited tools to perform action. A book with the name Creo Manufacturing 2.0 for Designers and Machinists is already available in the market on this topic from same author.

			•	The CMM sub-type is used to create programs for Coordinate Measuring Machines.

			•	The Sheetmetal sub-type is used to generate nc codes for sheetmetal forming machines.

			•	The Cast cavity sub-type is used to create cavity for casting the model part.

			•	The Mold cavity sub-type is used to create mold for the model part.

			•	The Harness sub-type is used to create wiring/piping for manufacturing/lay outing.

			•	The Process plan sub-type is used to generate manufacturing process plan. 

			•	The Additive Manufacturing sub-type is used to create products by 3D printing and other additive manufacturing techniques.

			 

			Drawing

			The Drawing radio button is used to create drawings from models and assemblies. The drawings are the paper representations of the models and assemblies for manufacturing.

			 

			Format

			The Format radio button is used to create format for drawings. These formats are later used in multiple drawings.

			 

			Notebook

			The Notebook radio button is used to create notes of ideas regarding the design. 

			 

			Open Tool

			The Open tool is used to open Creo Parametric files and import files of other modeling applications. The procedure to use this tool is given next.

			 

			•	Click on the Open tool from the File menu, Ribbon, or Quick Access Bar. The File Open dialog box will be displayed; refer to Figure-18.

			
				
					Figure-18. ​File Open dialog box

				

				
					[image: File_Open_dialog_box.png]
				

			

			 

			•	The left pane of the dialog box is used to access the common folders. Note that the files that are not saved but are in use in current session can be accessed by click on the In Session link from the Common Folders area in the left pane. 

			•	Click on the Views tool in the toolbar of the dialog box. The drop-down will be displayed as shown in Figure-19.

			
				
					[image: Views_drop-down.png]
				

				
					Figure-19. ​Views drop-down

				

			

			 

			•	Select the desired radio button to display the files in the desired manner.

			•	Click in the Type drop-down to specify the file type; refer to Figure-20.

			
				
					[image: Type_drop-down.png]
				

				
					Figure-20. ​Type drop-down

				

			

			 

			•	Double-click on the file under the Name column of the dialog box. The file will open. 

			 

			Save Tool

			The Save tool in the File menu is used to save the files. If you are saving a file for the first time then the Save Object dialog box will be displayed otherwise the file will be save automatically. The procedure to use this tool is given next.

			 

			•	Click on the Save tool from the File menu, Ribbon, or Quick Access Toolbar. If you are saving a new file for the first time then the Save Object dialog box will be displayed; refer to Figure-21.

			
				
					[image: Save_Object_dialog_box.png]
				

				
					Figure-21. ​Save Object dialog box

				

			

			 

			•	Specify the location of the file and click on the OK button from the dialog box to save it. 

			•	Now, if you again click on the Save button then the Save Object dialog box will not be displayed and the file will be automatically saved with same name and settings.

			 

			Save As

			There are three options in the File menu for Save As tool; refer to Figure-22. The Save a Copy option is used to create a copy of the file with new name. The Save a Backup tool is used to create a backup copy of the current file in the same directory. The Mirror Part tool is used to save a mirror copy of the current file. Note that the files saved by this tool automatically synchronize with the original file.  

			 

			
				
					[image: Save_As_options.png]
				

				
					Figure-22. ​Save As options

				

			

			 

			The procedure to use this tool is given next.

			 

			•	Click on the desired tool from the Save As cascading menu; refer to Figure-22. (Mirror Part in our case).

			•	The related dialog box will be displayed; refer to Figure-23.

			
				
					[image: Mirror_Part_dialog_box.png]
				

				
					Figure-23. ​Mirror Part dialog box

				

			

			 

			•	Specify the new name in the New name edit box and set the parameters as required.

			•	Click on the OK button from the dialog box. The part will be saved with the new name.

			 

			Print

			The Print tool is used to take printouts of the drawings/models for shop floor use. There are three options for printing; refer to Figure-24. The Print option is used to take print out of the object currently displayed in the drawing area. In this case, you can configure the printer as per your requirement. The Quick Print option is used to take quick prints of the objects. In this case, you can only select a printer. You cannot change the settings of the printer. The Quick Drawing option is displayed for models and assemblies. Using this option, you can quickly create drawings from the model/assembly and take print outs. The Prepare for 3D Printing option is used to prepare the model 3D Printing. You will learn more about this option later in the book. The Order 3D Print option is used to order the 3D printed model of current model/assembly online. The procedures to use these tools are given next.

			
				
					Figure-24. ​Print options

				

				
					[image: Print_options.png]
				

			

			 

			Print tool

			•	Click on the Print option from the Print cascading menu; refer to Figure-24. The Print dialog box will be displayed; refer to Figure-25.

			 

			•	Click on the [image: config_button.png] button and add the desired printer.

			•	Click on the Configure button from the dialog box and specify the desired parameters in the dialog box displayed; refer to Figure-26. Click on the OK button after specifying the parameters.

			
				
					[image: Print_dialog_box.png]
				

				
					Figure-25. ​Print dialog box

				

			

			   

			
				
					[image: Shaded_Image_Configuration_dialog_box.png]
				

				
					Figure-26. ​Shaded Image Configuration dialog box

				

			

			 

			•	Click on the OK button from the dialog box to print the object.

			 

			Quick Print tool

			•	Click on the Quick Print tool from the Print cascading menu. The Print dialog box will be displayed as shown in Figure-27.

			
				
					[image: Print1_dialog_box.png]
				

				
					Figure-27. ​Print dialog box

				

			

			 

			•	Select the desired printer from the Name drop-down in the dialog box.

			•	Set the desired parameters and then click on the OK button from the dialog box to print the objects.

			 

			Quick Drawing tool

			•	Click on the Quick Drawing tool from the Print cascading menu. The Quick Drawing dialog box will be displayed; refer to Figure-28. 

			•	Select the desired views from the View Layout area of the dialog box.

			•	You will learn more about the parameters later in the book. For the moment, click on the OK button from the dialog box. The Print dialog box will be displayed as discussed earlier.

			•	Click on the OK button from the dialog box to print.

			
				
					Figure-28. ​Quick Drawing dialog box

				

				
					[image: Quick_Drawing_dialog_box.png]
				

			

			 

			You will learn about 3D Printing options later in the book.

			 

			Close Tool [image: Close_button.png] 

			The Close tool is used to close the current file without closing the application. 

			 

			Manage File

			The Manage File options are used to manage files of Creo Parametric. There are five options available in this cascading menu; Rename, Delete Old Versions, Delete All Versions, Declare, and Instance Accelerator; refer to Figure-29. 

			
				
					[image: Manage_File_options.png]
				

				
					Figure-29. ​Manage File options

				

			

			 

			•	The Rename tool in the Manage File cascading menu is used to rename the current file. To rename the file, click on this tool. The Rename dialog box will be displayed; refer to Figure-30. Specify the desired name and click on the OK button from the dialog box.

			
				
					[image: Rename_dialog_box.png]
				

				
					Figure-30. ​Rename dialog box

				

			

			 

			•	The Delete Old Versions tool is used to delete all the previous versions of the file but to keep the latest version of the file. Note that as many times you save the file in Creo Parametric, it creates a new version of file so that anytime you can go back to previous versions. But more versions take more space on disk. So, the Delete Old Versions tool is used to delete the older versions. To delete the older versions of the file, click on the Delete Old Versions tool from the File menu. The Delete Old Versions dialog box will be displayed. Click on the Yes button from the dialog box to delete the older versions of the file.

			 

			•	The Delete All Versions tool is used to delete the file and its history from session and working directory. This tool works in the same way as the previous tool works.

			 

			•	The Declare tool is used to declare any axis or datum as global for assembly purpose. For using this tool, you must have a notebook active in session. You can create a notebook by using the New dialog box. Once you have declared a datum as global, each part of assembly can use it for locating itself.

			 

			•	The Instance Accelerator tool is used to used to delete all the useless data of the current file so that the work can be done more efficiently on the file. Using this tool, you can delete the previous versions of the file that are of no use now. On selecting this tool, the Instance Accelerator dialog box will be displayed; refer to Figure-31. Click on the Purge button to accelerate the system processing.

			
				
					[image: Instance_Accelerator_dialog_box.png]
				

				
					Figure-31. ​Instance Accelerator dialog box

				

			

			 

			Model Properties

			The Model Properties option is available in the Prepare cascading menu of the File menu; refer to Figure-32. This tool is used to change the properties of the model. The procedure to do so is given next.  

			
				
					[image: Model_Properties_option.png]
				

				
					Figure-32. ​Model Properties option

				

			

			 

			•	Click on the Model Properties option from the Prepare cascading menu. The Model Properties dialog box will be displayed; refer to Figure-33.

			 

			Material Selection

			Using the options available in the Materials area of the dialog box, you can change the properties of the model related to material. The steps are given next.

			 

			•	Click on the Change link button next to Material in the Materials area of the dialog box; refer to Figure-34.

			
				
					[image: Model_Properties_dialog_box.png]
				

				
					Figure-33. ​Model Properties dialog box

				

			

			 

			•	Open the desired directory and double-click on the desired material from the list of material to add it to the list of materials used for the current model. The material will be added in the list at the bottom as shown in Figure-35.

			•	If you want to edit the parameters of the material before applying it to model, then double-click on the material in the Materials in Model area of the dialog box. The Material Definition dialog box will be displayed; refer to Figure-36.

			
				
					Figure-34. ​Materials dialog box
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					[image: Materials_in_Model.png]
				

				
					Figure-35. ​Material to be applied to model

				

			

			   

			
				
					[image: Material_Definition_dialog_box.png]
				

				
					Figure-36. ​Material Definition dialog box

				

			

			 

			•	The dialog box allows you to change the mechanical and thermal properties by using the Structural and Thermal tabs, respectively. Similarly, you can change the Miscellaneous properties and appearance of the material.

			•	After setting the desired properties, click on the OK button from the dialog box.

			•	Make sure the desired material is selected in the Materials in Model area of the dialog box as assigned; refer to Figure-37 and then click on the OK button from the dialog box.

			•	If the desired material is not assigned the right-click on the desired material from the Materials in Model area. A shortcut menu will be displayed; refer to Figure-38.

			
				
					Figure-37. ​Material assigned
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					Figure-38. ​Shortcut menu for material
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			•	Click on the Assign option from the menu to assign the material and then click on the OK button from the dialog box.

			 

			Unit System

			The Unit option in the Model Properties dialog box is used to change the unit system for modeling. The procedure to change the unit system is given next.

			 

			•	Click on the Change link button for Units in the Materials area of the dialog box. The Units Manager dialog box will be displayed; refer to Figure-39.

			
				
					[image: Units_Manager_dialog_box.png]
				

				
					Figure-39. ​Units Manager dialog box

				

			

			 

			•	Select the desired unit system from the list in the dialog box and click on the Set button to apply the units. The Changing Model Units dialog box will be displayed; refer to Figure-40.

			
				
					[image: Changing_Model_Units_dialog_box.png]
				

				
					Figure-40. ​Changing Model Units dialog box

				

			

			 

			•	If by mistake you have designed your model in inches or mm and you want the system to interpret 1” as 1 mm or 1 mm as 1”, then click on the Interpret dimensions radio button.

			•	If you want to convert your model unit system from inch to mm or vice-versa, then click on the Convert dimensions radio button.

			•	After selecting the desired radio button, click on the OK button from the dialog box. The selected unit system will be applied for the model.

			 

			Sometimes, we need to use a unit system different to standard unit system. In those cases, you can create a unit system as per your requirement. The steps are given next.

			 

			•	Click on the New button from the Unit Manager dialog box. The System of Units Definition dialog box will be displayed; refer to Figure-41.

			
				
					[image: System_of_Units_Definition_dialog_box.png]
				

				
					Figure-41. ​System of Units Definition dialog box

				

			

			 

			•	Click on the edit box of Name area and specify the desired name in it.

			•	Select the desired radio button from the Type area of the dialog box. 

			•	From the Units area, select the units for each property.

			•	Click on the OK button from the dialog box. The unit system will be created with the specified name.

			•	You can set the newly created unit system as discussed earlier.

			 

			 

			Mass Properties

			Using the Mass Properties option, you can change the density, inertia and other mass properties of the model. The procedure to change the mass properties is given next.

			 

			•	Click on the Change button next to Mass Properties in the Model Properties dialog box. The Mass Properties dialog box will be displayed; refer to Figure-42. 

			
				
					[image: Mass_Properties_dialog_box.png]
				

				
					Figure-42. ​Mass Properties dialog box

				

			

			 

			•	Specify the desired value for density in the Density edit box.

			•	Click on the Calculate button. Based on the specified density, the other properties are calculated and displayed in the dialog box.

			•	You can generate report of the properties by using the Generate Report button.

			•	Now, close the dialog box by clicking on the Close button. 

			 

			You will learn about other options in the Model Properties dialog box and ModelCHECK options in Prepare cascading menu of the File menu later in the book.

			 

			Send Options

			The Send options in the File menu are used to share the model files with peers. There are two options available for sending a file to peers; Mail Recipient (As Attachment) and Mail Recipient (As Link). The procedure for both the options is similar. The procedure is given next.

			 

			•	Click on the Mail Recipient (As Attachment) option from the Send cascading menu in the File menu; refer to Figure-43. The Send As Attachment dialog box will be displayed; refer to Figure-44.

			
				
					[image: Mail_Recipient_option.png]
				

				
					Figure-43. ​Mail Recipient option

				

			

			 

			
				
					[image: Send_As_Attachment_dialog_box.png]
				

				
					Figure-44. ​Send As Attachment dialog box

				

			

			 

			•	Select the Create a ZIP file containing the attachment check box if you want to compress the file before sending it as attachment.

			•	Click on the OK button from the dialog box to send it. The default messenger will be displayed.

			•	Type the e-mail address of your peer and send it.

			 

			Manage Session

			The tools in the Manage Session cascading menu are used to manage session of modeling. There are about 10 tools available in the Manage Session cascading menu; refer to Figure-45. Some of the options are discussed next.

			 

			Erase 

			The Erase options are used to remove the files saved in the temporary memory. Any file that is not saved by using the Save button are saved in the temporary memory while working. We need to free up this memory for good performance of Creo. There are three options available in Manage Session cascading menu for erasing session data; Erase Current, Erase Not Displayed, and Erase Unused Model Reps. The procedure for all the three tools is similar; click on the tool and then click on the OK button from the dialog box displayed. 

			 

			Erase Current: The Erase Current option is used to erase the current part files from the memory.

			 

			Erase Not Displayed: The Erase Not Displayed option is used to erase the components that are not displaying but are in the session.

			 

			Erase Unused Model Reps: The Erase Unused Model Reps option is used to erase the representation of the model (part/assembly). You will learn more about representations later in the book. 

			
				
					[image: Manage_Session_cascading_mneu.png]
				

				
					Figure-45. ​Manage Session cascading mneu

				

			

			 

			Select Working Directory

			The Select Working Directory option in the Manage Session cascading menu is used to set the desired directory as working directory. The procedure is given next.

			 

			•	Click on the Select Working Directory option from the Manage Session cascading menu of the File menu. The Select Working Directory dialog box will be displayed; refer to Figure-46.

			•	Select the desired directory icon and click on the OK button from the dialog box. The selected directory will be set as working directory.

			
				
					[image: Select_Working_Directory_dialog_box.png]
				

				
					Figure-46. ​Select Working Directory dialog box

				

			

			 

			Options

			The Options button in the File menu is used to access the options to configure Creo Parametric. There are lots of options for configuration but we will discuss some important options only. The procedure to use the options is given next.

			 

			•	Click on the Options button from the File menu. The Creo Parametric Options dialog box will be displayed; refer to Figure-47.

			
				
					[image: PTC_Creo_Parametric_Options_dialog_box.png]
				

				
					Figure-47. ​PTC Creo Parametric Options dialog box

				

			

			 

			•	Click on the Model Display option from left area of the dialog box. The dialog box will be displayed as shown in Figure-48.

			•	Click on the drop-down for Default model orientation and select the desired orientation. Some of the designers prefer to use Isometric as default orientation.

			•	Set the shade quality to desired level by using the spinner in the Shaded model display settings area of the dialog box.

			•	Click on the Sketcher option from the left pane of dialog box. The options related to sketching environment will be displayed.

			•	Select the Lock user defined dimensions check box and select the Make the sketching plane parallel to the screen check box.  The Lock user defined dimensions check box forces the dimensions to be locked after the user input and you cannot change the dimensions by dragging or by applying relations. The Make the sketching plane parallel to the screen check box is used to make the sketching plane parallel to the screen when you enter the sketching environment from modeling environment. 

			•	Click on the System Appearance option from the left pane of dialog box and expand the Graphics node of Global Colors options; refer to Figure-49. Click on the Background button and select the white color.  

			•	You will learn about the other options later in the book. Click on the OK button. A dialog box will be displayed asking you whether to store the specified settings in a configuration file. Click on the Yes button from the dialog box and save the configuration file at desired location.

			
				
					[image: Model_Display_page_of_PTC_Creo_Parametric_Options_dialog_box.png]
				

				
					Figure-48. ​Model Display page of Creo Parametric Options dialog box

				

			

			 

			
				
					[image: Graphics_Colors_options.png]
				

				
					Figure-49. ​Graphics Colors options

				

			

			 

			Switching between Files

			To switch between various model files, click on the Windows button in the Quick Access Toolbar; refer to Figure-50.

			
				
					[image: Window_button_in_the_Quick_Access_Toolbar.png]
				

				
					Figure-50. ​Window button in the Quick Access Toolbar

				

			

			 

			Select the part file that you want to work with.

			 

			In this chapter, we learned about the basics of the Creo Parametric Interface. In the next chapter, we will work on the sketching environment and its function.

			 

			Shortcut Keys and Mouse Functions 

			in Creo Parametric

			There are various ways to use tools of Creo Parametric, like you can click on the tool directly, you can use ALT+key to select a tool, you can use CTRL+key to activate a tool, or you can use right-click shortcut menu. Some of the most common shortcuts and mouse functions are discussed next.

			
				
					[image: Keyboard_Shortcuts.png]
				

				
					Figure-51. ​Keyboard Shortcuts

				

			

			 

			Keyboard Shortcuts

			Press the combination of CTRL and other key to activate the respective function as shown in Figure-51.

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			ALT Key Menu

			Press ALT key once while working in any environment of Creo Parametric. The key tips will be displayed; refer to Figure-52. Press the desired key from keyboard to activate the respective option.

			
				
					[image: ALT_key_tips.png]
				

				
					Figure-52. ​ALT key tips

				

			

			 

			Mouse Functions
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					Figure-53. Mouse functions
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					Figure-54. Mouse Control

				

			

			


		
			 

			 

			 

			 

			Chapter 2

			 

			 

			Sketching 

			 

			 

			 

			 

			 

			 

			 

			 

			 

			
				


				
					Topics Covered

				

			

			 

			 

			 

			 

			The major topics covered in this chapter are:

			 

			•	Starting Sketching environment.

			•	Setting Grid and other parameters.

			•	Sketching tools

			•	Sketch editing tools

			•	Dimensioning tools

			•	Geometric Constraints

			 

			 

			 

			 

			 

			 

			 

			 

			[image: Sketching_environment.png] 

			 

			 

			 

			 

			 

			Starting Sketching Environment

			Welcome to Sketching environment. The sketching environment is used to draw or manipulate sketches. The procedure to start sketching environment is given next.

			 

			•	Click on the New button from the File menu, Ribbon, or Quick Access Toolbar. The New dialog box will be displayed; refer to Figure-1.

			
				
					[image: New_dialog_box_1.png]
				

				
					Figure-1. ​New dialog box

				

			

			 

			•	Select the Sketch radio button from the dialog box and specify the name of the file in the Name edit box.

			•	Click on the OK button from the dialog box. The sketching environment will be displayed; refer to Figure-2.

			
				
					[image: Sketching_environment.png]
				

				
					Figure-2. ​Sketching environment

				

			

			 

			Setting Up Grid

			The Grid is used to help the designer in creating sketches. It is not always necessary to use the grid, it’s more often up to the designer. The procedure to setup and display the grid is given next.

			 

			•	Click on the Grid button from the Setup panel in the Ribbon. The Grid Settings dialog box will be displayed; refer to Figure-3. 

			•	Specify the desired values for the grid and then click on the OK button from the dialog box. The values for the grid will be saved in the configuration.

			•	To display the grid, click on the Sketcher Display Filters drop-down in the In-Graphics toolbar; refer to Figure-4. The list of options will be displayed.

			
				
					[image: Grid_Settings_dialog_box.png]
				

				
					Figure-3. ​Grid Settings dialog box

				

			

			 

			
				
					[image: Grid_Display_option.png]
				

				
					Figure-4. ​Sketcher Display Filters

				

			

			 

			•	Select the Disp Grid check box to display the grid. To hide the grid, you need to clear the check box.

			 

			Sketching Tools

			There are various sketching tools available in the Sketching panel of the Sketch tab in the Ribbon; refer to Figure-5.

			
				
					[image: Sketching_Tools.png]
				

				
					Figure-5. ​Sketching Tools

				

			

			 

			We will discuss one by one the procedures to use the tools in the Sketching panel.

			 

			Line Tools

			There are two tools in Creo Parametric to create lines in the drawing; Line Chain and Line Tangent. The Line Chain tool is used to create a chain of lines. The procedure to create the line chains is given next.

			 

			Line Chain tool [image: Line_Chain_tool.png] 

			 

			•	Click on the down arrow next to Line Chain tool. The list of the tools will be displayed as shown in Figure-6.

			
				
					[image: Line_Tools.png]
				

				
					Figure-6. ​Line Tools

				

			

			 

			•	Click on the Line Chain tool from the list of tools. An end point will get attached to the cursor and you are asked to specify a point on the screen.

			•	Click at the desired location to specify the start point of the line. A rubber band line will get attached to the cursor.

			•	Stretch the line in the desired direction and click at the desired point to create the line. As soon as you specify the end point, you are asked to specify the next point.

			•	Keep on specifying the end points until you get the desired lines.

			 

			After specifying the start point of the line, if you: 

			 

			•	Move the cursor in horizontal direction. Then the - symbol gets attached to the line; refer to Figure-7. This - symbol designates that the line is constrained as Horizontal line. You will learn about the constraints later in the chapter.

			
				
					[image: Horizontal_line.png]
				

				
					Figure-7. ​Horizontal line

				

			

			 

			•	Move the cursor in the vertical direction. Then the | symbol gets attached to the line; refer to Figure-8. Similar to the Horizontal constraint, it designates Vertical constraint.

			
				
					[image: Vertical_line.png]
				

				
					Figure-8. ​Vertical line

				

			

			 

			Line Tangent [image: Line_Tangent_tool.png] 

			•	Click on the Line Tangent tool from the Line drop-down in the Ribbon. You are asked to select the two entities to which the line should be tangent.

			•	Select the two circular entities at the places where you want to specify the start point and end point of the line. Refer to Figure-9. 

			
				
					Figure-9. ​Tangent lines

				

				
					[image: Tangent_lines.png]
				

			

			 

			•	Note that [image: Tangent_symbol.png] is displayed at the contact points between circles and lines. The [image: Tangent_symbol.png] refers to Tangent constraint.

			 

			Rectangle Tools

			There is a list of four tools in Creo Parametric that are used to create rectangles; Corner Rectangle, Slant Rectangle, Center Rectangle, and Parallelogram. The procedure to create rectangles by using these tools is given next.

			 

			Corner Rectangle

			The Corner Rectangle tool is used to create rectangle by using the corner points of the rectangle. The procedure is given next.

			 

			•	Click on the Corner Rectangle tool from the Rectangle drop-down; refer to Figure-10. You are asked to specify the first corner point.

			
				
					[image: Corner_Rectangle.png]
				

				
					Figure-10. ​Corner Rectangle

				

			

			 

			•	Click in the drawing area to specify the first point of the rectangle. The other corner point will get attached to the cursor.

			•	Click to specify the other corner point. The rectangle will be created.

			•	Press the middle click to exit the tool. The rectangle will be displayed; refer to Figure-11.

			
				
					[image: Rectangle_created.png]
				

				
					Figure-11. ​Rectangle created

				

			

			 

			Slanted Rectangle

			The Slanted Rectangle tool is used to create rectangles aligned at some defined angle. The procedure is given next.

			 

			•	Click on the Slanted Rectangle tool from the Rectangle drop-down. You are asked to specify the first point of the rectangle.

			•	Click to specify the first point of the rectangle. End point of a rubber-band line will get attached to the cursor.

			•	Click to specify the end point of the line at desired inclination. The adjacent side of the rectangle will get attached to the cursor.

			•	Click at the desired distance to create the rectangle.

			•	Press the middle mouse button to exit the tool.

			 

			 

			Center Rectangle

			The Center Rectangle tool is used to create a rectangle using the center point of the rectangle and a corner point of the rectangle. The procedure to create a rectangle by this tool is given next.

			 

			•	Click on the Center Rectangle tool from the Rectangle drop-down. You are asked to specify the center point of the rectangle.

			•	Click in the drawing area to specify the center point. The corner point of the rectangle will get attached to the cursor; refer to Figure-12.

			
				
					[image: Corner_point_of_center_rectangle_attached_to_cursor.png]
				

				
					Figure-12. ​Corner point of center rectangle attached to cursor

				

			

			 

			•	Click to specify the corner point of the rectangle.

			 

			Parallelogram

			Parallelogram as the name suggests is made up of parallel sides. The procedure to create the parallelogram is given next.

			 

			•	Click on the Parallelogram tool from the Rectangle drop-down. You are asked to specify the start point of baseline of the parallelogram.

			•	Click in the drawing area to specify the point. End point of a rubber band line will get attached to the cursor.

			•	Click to specify the end point of the line. Corner point of the parallelogram will get attached to the cursor.

			•	Click at the desired inclination to specify the corner point of the parallelogram. The parallelogram will be created.

			•	Press the middle mouse button to exit the tool.

			 

			Note that now onwards, we will not write the step to exit the tool. By default, you need to press the middle button mouse to exit the tool.

			 

			Circle Tools

			The tools available in the Circle drop-down are used to create circle with various methods. There are four tools available in the Circle drop-down; Center and Point, Concentric, 3 Point, and 3 Tangent. The procedures to create circles by these tools are given next.

			 

			Center and Point tool

			The Center and Point tool is used to create circle by specifying center point and one point on its circumference. The procedure to use this tool is given next.

			 

			•	Click on the Center and Point tool from the Circle drop-down; refer to Figure-13. You are asked to specify the center point of the circle.

			
				
					[image: Circle_drop-down.png]
				

				
					Figure-13. ​Circle drop-down

				

			

			 

			•	Click in the drawing area to specify the center point of the circle. The cursor gets attached to a point on the circumference of the circle.

			•	Click at the desired distance to specify the radius of the circle. The circle will be created.

			•	Press the middle mouse button to exit the tool.

			 

			Concentric tool

			The Concentric tool is used to create circle concentric to earlier created circles/arcs. The procedure is given next.

			 

			•	Click on the Concentric tool from the Circle drop-down. You are asked to select an arc or circle.

			•	Select the arc/circle, a point on circumference of circle will get attached to the cursor with center of the circle coinciding with selected arc/circle‘s center; refer to Figure-14.

			•	Click to specify the radius of the circle.

			
				
					[image: Concentric_circle.png]
				

				
					Figure-14. ​Concentric circle

				

			

			 

			3 Point Circle

			The 3 Point Circle tool is used to create a circle with the help of three circumferential points. The procedure is given next.

			 

			•	Click on the 3 Point Circle tool from the Circle drop-down. You are asked to specify the first circumferential point.

			•	Click in the drawing area to specify the first point of the circle. You are asked to specify the second point on the circumference of circle.
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